Jump to content
Corsair Community

What happened to the iCue Library

Recommended Posts

Had to reinstall windows last night and thus, had to reinstall iCue.  When i went to download my previous theme from the iCue library, I get a 404 error where page no longer exists.  Has this page moved?

Link to comment
Share on other sites

Posted (edited)

Cached pages from search engines are likely going to be wrong for a bit.  Try to navigate there manually from the new website.  If you still get an error, post the link and the location/language from the bottom as well as the browser you are using.  But I think that may be the issue... I can't find it either.  

Edited by c-attack
Link to comment
Share on other sites

On 5/23/2023 at 5:43 PM, Technobeard said:

Thanks guys, I've reported this.

Yeah I've noticed a few pages have been bugging out at random.  Sometimes they load, other times I have to close my browser and clear history then they load.  It's weird.  But I'm gonna chalk it up to a possible new system/coding they're using for the new site remap.  Which looks great btw.  I just wish it worked half the time.  Could be my Opera browser too.  But I dunno.  New site is a bit buggy.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...