Jump to content
Corsair Community

Bricked keyboard


Recommended Posts

I have a fairly new K55 keyboard. I decided to try out the macro keys. (MR    G5    Shift-End    Delete    MR).  When programmed as instructed it would perform the task desired as well as open Powerpoint and 17 tabs of Office. I read the forums and found out I need to install iCue. So I did - from your latest downloads. It told me that there was a firmware update for the keyboard, so I had it do that. Then it told me the update failed, so I had it do it again.

Now - the keyboard still works as a keyboard, but I have no control over the RGB lighting on the keyboard, the FN-F4 reset does not work, the MR key acts like it's working but it doesn't recognize when I press any Gkeys, it won't go into the mode where I can check the activation/deactivation of the Gkeys. It is half the keyboard I had before downloading iCue.

I have uninstalled the keyboard, then checked for hardware changes to reinstall it.

I have rebooted my computer.

I have unplugged the usb cable to the keyboard, left it unplugged for 10 minutes, then plugged back into a USB3 port instead of USB2.

I have looked for updates to the keyboard on your support site - none found.

I have had iCue look for driver/firmware updates to the keyboard - it says it is up to date (I guess - the keyboard doesn't show up as a device)

I now have a rolling-rainbow keyboard and I wish I didn't. 

Do you have a solution to my problems?

Corsair gaming k55 RGB keyboard

p/n ch-9206015-na/rf

s/n 0630211494300

rmn rgp0031

Win10 Home

iCue 4.20.169

I rebooted and restarted iCue - it said there was a new firmware update for the keyboard - i didn't write it down - think it was v.30.9.  Looked like it was the same that you said you had updated on another thread dealing with the macro issue. Had it update and then got a notification that the firmware update had failed again. 

On the home screen of iCue, it shows a picture of a K55 keyboard with a red triangle over it. Hoovering mouse over triangle reveals it says, "Not available." If I click on the keyboard settings it has a blank current layout and a brightness slider that will not work.

You got me! I fell for your sorcery!

Link to comment
Share on other sites

OK - don't know what happened, but keyboard is now operating like it was at first. 

I can control the backlighting.

I can program the G keys

When the macro is activated, it is performed, then it opens powerpoint, 14 tabs of office (that's better than 17) and my settings tab for mswindows. iCue still shows the K55 to be unavailable. I'm going to quit while I'm ahead.

If you have suggestions, I'm listening, but so far I'm not impressed with my purchase.

Link to comment
Share on other sites

The red triangle is a generic warning error that can have multiple meanings. However, for most keyboards this means some type of initialization error on boot. If it happens again, try a quick unplug and reconnect of the KB usb. This usually solves the issue. If this is an every boot type of condition, we’ll then you know what to do and this board needs to be returned. 
 

It seems like there might have been multiple overlapping issues, including a bad firmware load. Be careful of aggressive anti-virus software, KVM switches, or using some other type of usb hub when loading a firmware update. 
 

When the device was in red triangle mode, it is no longer in “software mode” and anything you programmed in CUE won’t work. It should then be in Hardware Mode. Lighting and macros must be saved to the device memory in order to function in that state. To complicate things, there are 3 different versions of the “K55” each with different capabilities in this regard. 
 

If the macros are not responding as expected when CUE is running and no red triangle, try a quick repair install of the program through the Windows Settings App. Select Corsair iCUE and choose “modify”. This usually cleans up weird issues between the program and OS and I would do this after a bad firmware attempt regardless. 

Edited by c-attack
Link to comment
Share on other sites

Question for you:

How many other USB devices do you have directly connected to the motherboard USB?

Link to comment
Share on other sites

Well, I tried modifying the iCue software. Took longer than I thought it would. Rebooted and it still didn't work. I looked up my paperwork and I had purchased the keyboard refurbished from Amazon for $31. I considered returning it (still had a six day window) and getting something else. Could not duplicate the price I got it for and other brands didn't have function keys to the left of the keyboard. I thought that was rather important - reaching up above the keyboard to hit a function key would be very disruptive to repetitive typing. I tried rebooting one more time.

This time, I was advised one more time that firmware was updateable on the keyboard. I told it to 'go for it'. The keyboard was successfully updated with 30.09. Everything seemed to operate correctly. I was able to program a G key and it performed the macro without summoning PowerPoint or Office. So, I can keep my keyboard. Thanks for your help

I am assuming that I no longer need the iCue software - it's main purpose to me has been to update the keyboard. Hopefully next time I reboot the macro will still be functional.

Link to comment
Share on other sites

You will need the software active for the use of the G-keys, to change lighting, and possibly for remapping keys or certain KB programmable actions. You can use the KB without the software, but functionality is usually reduced in some way. You may still be able to save something to those G keys, but it will depend on what the action is and which of the K55 models you have. 

Link to comment
Share on other sites

  • 4 weeks later...

i just skimmed this post non of the replies but coming from a fresh install of windows 10 i have a k70 lux rgb worked fine for as long as i have had it reinstalled windows got to the pont to install icue it installs fine gets windows disconnect sound when icue launchs icue see my coid pro rgb no problem but doesnt see my k70 keyboard hmmmmm restarts pc still nothing ok. unplugs keyboard runs driver booster's clean unplugged devices function restarts pc wait for icue to load plugs keyboard into the same usb port still nothing goes and plugs k70 into different usb port and icue sees it no problem hmmmm goes and plugs different known working usb device into the bad usb port and nothing yep found a bug in icue that usb port is dead and from what i read from older posts about icue and usb issues its gonna take a full freakin reinstall of windows to fix this and get all usb ports functiong again cause icue doesnt know how to handle usb hooks when the keyboard is already plugged in when u fresh install icue ive read in those posts a corsair person blaming microsoft for these issues

for a hassle free install of icue MAKE SURE U UNPLUG ALL CORSAIR PRODUCTS FROM UR PC BEFORE INSTALL or u might end up with a partially bricked usb hub/port/ports

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...