Jump to content
Corsair Community

Void elite wireless doesn't turn on after updating them


Recommended Posts

I have recently updated icue to v4 and found that my void elite weren't updated. When I pressed update nothing really happened. I don't know if it even updated it correctly. The thing is that now they don't even turn on at all. Not a single led turns on whenever I press the button. I have tried the repairing method with the dongle and still nothing.

 

It's like they are dead. Battery was over 50% when I updated them so I don't think that's the issue.

 

Thanks in advance, any type of help is greatly appreciated.

Link to comment
Share on other sites

  • Corsair Employees

Hi Pablo Paramio,

 

I suggest attempting a soft reset. To soft reset your headset:

 

  1. Make sure your headset is currently unplugged.
  2. Make sure your headset is powered on.
  3. Hold the Mute button on the headset down for about 15 seconds.
  4. Hold down the power button until the headset turns on.
  5. Test your headset and see if the issue is resolved.

 

If that does not work, then please open a ticket at https://help.corsair.com, our support will take care of you.

Link to comment
Share on other sites

Thanks for the reply,

 

I have tried this, however I am having trouble in step 2 since they don't turn on at all. I have already opened a ticket but it is my third day without a reply. The reason I am seeking out help over here is because I know from past troubleshooting experiences that I don't get answered very often there.

 

Once again, thanks for the reply.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...