Jump to content
Corsair Community

iCUE v3.9.93 Patch Notes


Corsair James

Recommended Posts

  • Corsair Employees

Hi everyone,

 

I’ve included the patch notes for the previous two versions into one so you all can see the changes we’ve done.

 

Patch Notes for iCUE v3.9.93

 


  •  
  • Sensor Logging is now started and stopped manually. Users will now be able to select sensors first and start the logging without the software creating multiple .cIamgsv files in the documents folder
     
  • Resolved an issue with firmware updates on Platinum Coolers. Please note there is a known issue with updating Platinum Coolers when there are two identical coolers (i.e., 2x H100i Platinum Coolers or 2x H115i Platinum Coolers). If there are systems that will be using both on the same motherboard, please unplug each device separately to do an update (if necessary)
     
  • Resolved an issue with incompatible settings with device hardware profiles
     
  • Resolved an issue with Commander Pro’s Quiet Performance Mode running at a higher speed than designed
     
  • Resolved an issue with VOID Visualizer drop down icons displaying incorrectly
     
  • Resolved an issue with ticking hard drives by allowing users to enable/disable the HDD widget with our CPUID SDK. We have confirmed the ticking issue is due to certain HDD models and is caused by how monitoring software polls the device – users who experience this issue is recommended to disable the HDD widget in Settings
     
  • Resolved an issue with Dark Core and Dark Core SE displaying incorrect lighting
     
  • Improved how two of the same device is displayed in the System Tray
     
  • Hydro Series Platinum Coolers now have Static Color under Hardware Lighting
     
  • Resolved an issue with audio devices displaying incompatible effects
     
  • Resolved an issue with iCUE crashing upon system wakeup from sleep
     
  • Improved the image of iCUE in System Tra
  • Resolved an issue with iCUE crashing when using more than one mouse and opening DPI tab with certain languages
     
  • Resolved an issue with Dashboard and Space with video cards displaying incorrect data
     
  • Resolved an issue with Spec Omega displaying firmware version incorrectly
     
  • Resolved an issue with Obsidian 1000D displaying certain lighting effects incorrectly
     
  • Resolved an issue with graphs for widgets not displaying Min and Max values
     
  • Resolved an issue with iCUE exporting system logs and missing general system information
     
  • Resolved an issue with Action – Timer repeating with 0 and 1 times being the same
     
  • Resolved an issue with sensors not displaying the entire name of a CPU
     
  • Resolved an issue with LL fans flickering when connecting to a H115i RGB Platinum
     
  • Resolved an issue with Vengeance RGB PRO multicolor effect and DIMM rotation
     
  • Resolved an issue with Up and Down Arrows with Actions – Timer
     
  • Implemented new device support for Hydro X with our Commander Pro and Lighting Node Pro – Hydro X news and availability will be coming soon in the near future. Please stay tuned.
     
  • Resolved an issue with graphs and PRO coolers when using 30 minute intervals
     
  • Resolved an issue with Corsair Service failing to start upon system bootup
     
  • Battery Status child widgets can now be renamed
     
  • Resolved other various minor issues and bugs
     

 

Update: There is a known issue with a certain VIA chipset and wireless products that may result in a crash when waking from sleep. The VIA 3.0 chipset in question is using driver version: 10.0.17134.1. We recommend, if possible, to switch your wireless dongle to a different USB port that isn't using this specific chipset to avoid any potential issues with device performance and iCUE.

Link to comment
Share on other sites

This version is broken.

 

It auto updated, uninstalled a fully working version. Then refused to install beyond 59%.

 

Now i have $500 worth of products here puking rainbow because the software refuses to install.

 

I've had a support ticket open for a week with not a single reply/response on it.

 

I've previously had a forum post here about it that got 0 replies...

 

Is there any support that can come to my aid to get this issue resolved?

Link to comment
Share on other sites

You guys have got to get a handle on the CPU usage problems with iCUE. It constantly chews up 3-5% CPU usage on my i7 7700k 4.8Ghz CPU doing nothing in the background. That's with a static lighting profile, and just macro keys assigned to my K95 g-keys.

 

If I leave the Corsair Service running, that's another 2-3% CPU usage stolen for no good reason since I find that I can disable it and iCUE works all the same.

 

This is unacceptable. Please comment on this CPU usage because it is really no good. You need to bear in mind that if I am seeing 5% CPU usage in Task Manager for iCUE.exe, that means really 1 of my cores is being used up to 45-50% because hyperthreading doubles logical core count, but in reality you only get 4 real cores that can do single threaded work each. If you are taking up ~50% of a single core, then I am really only looking at 3.5 cores available for gaming. With modern games using 4, 6 or even 8 cores, I cannot justify dedicating over half a core to a background process that's only purpose for me is to execute macros when I need them.

Link to comment
Share on other sites

Why are previous versions of iCUE not available on the website anymore? (https://www.corsair.com/us/en/downloads) Or am i just blind and not seeing it?

 

iCUE v3.8.91 was buggy for me and now iCUE v3.9.93 is giving me random blue screens with "power_driver_failure"

 

I tried everything, every last little option I could find to solve the problem including a fresh re-install of Windows and the only thing that worked was just not installing iCUE v3.9.93

 

Not being able to roll back to a previous version that was stable for me is a huge inconvenience.

Link to comment
Share on other sites

I'm slowly getting really annoyed by this iCue software...

If its not fixed before i need to renew my hardware i will never buy a corsair product again..

 

First version i ever had:

0 problems, but only compatible with my void RGB wireless headset.. (had to use Link for the cooler)

 

So it got updated:

Broke my headset functionality, side tone always turned off when the mic was muted/unmuted.. Even though the slider in iCue was still at the top..

You had to wiggle the slider to get side tone back, or hold the mute button on the headset twice to disable/re-enable it...

Autoshutdown toggle didnt work, even though it was disabled the headset still tried to shutdown...

 

Next update:

So, still running arround with the SideTone Bug, but at least now my H115i was showing in iCue as well

Auto shutdown got fixed though!

So for the most part it all sort of worked..

 

Next update:

Still no SideTone fix and they broke the H115i functionallity.

iCue sometimes randomly decides to detect a second H115i, but configuring it has no use..

And the original was no longer working, so there you are sitting with massive fans blowing @100% all night driving you nuts!

Then when you reboot it shows just the one again, but it lost all its profiles?!?!!!

So i just forgot about it and downloaded Link to burn the profile in the H115i's memory (Because somehow iCue still does not support this)..

(If you want something done, you always have to do it yourself.......)

 

Final update (Latest version 3.9.93):

As far as i can see they finally fixed the sidetone bug. (As far as i can see, only been running for couple of hours now)

BUT! it did get better, now my H115i is not even showing up anymore... (Clap, Clap... GG Corsair...)

Rebooting, reinstalling.. none work.. (Once Again, Clap Clap...)

 

 

Looking forward for the new update!!

Lets see what more they can break.......

Link to comment
Share on other sites

yeah, this buggy icue software is trash, i switched from logitech and NZXT to corsair, because nzxt cam software was so buggy too, and Corsair link seemed just fine at this time, but now i have all devices from corsair, and i have to use this trash icue. @ontopic: this icue 3.9.93 tells me i can update the firmware of my dark core rgb and my K95 platinum, but every time i try to update my k95 it disconnects and the update fails, and when i update my dark core successfully with the new firmware, at the next startup it icue tells me again that the mouse needs an update... and since when has the powermeter readings been deleted in the AX1500i tab?
Link to comment
Share on other sites

We aren't making iCUE any better just by calling it trash.

 

After all, look around, iCUE is orders of magnitude superior to anything else.

 

Perfect? no...I'm waiting till it is better so I can continue using it. (my gripe is CPU usage as you know, but I see they're working on that still)

 

What I see is Corsair has gone in great depth with iCUE, I can see the effort and I respect that.

 

I'm sure is gonna be great for all of us at some point.

Link to comment
Share on other sites

If anyone else has the failed to install at 59% bug with these version. Here's how i finally fixed it.

 

After a back and forth convo with support, they ended up giving me an older version of icue (link below). This enabled me to do a fresh install of a version i already had working previously.

 

http://downloads.corsair.com/Files/CUE/iCUESetup_3.1.133_release.msi

 

 

- Removed the unit from my case and installed it into another PC.

 

- Flashed the link unit with the latest firmware (using the above older version)(force flash, even know it already had the latest on it.)

 

- re-installed it into my main PC. &Moved the link to a new mobo usb header that hadn't been used before. (in my case i moved from usb header 4 to 6.)

 

- removed all corsair software both icue & link related, including all registry entries manually from my main PC.

 

- ONLY installed the raw full version of older version of icue. (see link above)

 

- Then once this version was working, i was then able to install the latest version from scratch using the direct download from the corsair website. rather than the auto updater built into the software.

 

Conclusion:

I have no idea wtf happened in the first place. I used the built in software updater and it corrupted the driver install or something that meant there was some perpetual error going on. And only once doing a fresh forced flash from another machine and a new usb header on the mobo did this fix the issue.

 

Something is up with the software updater when it also attempted to firmware flash the unit at the same time as the software is updating, causing this conflict to take place.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...