Jump to content
Corsair Community

Problem with USB ports and headsets


Demagole
 Share

Recommended Posts

Hello everyone and thanks for coming on this post.

 

I bought the K70 Rapidfire 1 week ago and I'm completely happy with it.

Love the feeling of the switch, the backlighting and the font.:biggrin:

I have been connecting multiple peripherics into the back USB port like Printers, USB drive, my phone and even a launchpad and all of them worked perfectly.

 

Until I had a problem today with my headset: A G633. I can't seem to make it work.:(:

Firstly it didn't light up when I connected it. I disabled XHCI intel USB technology and now the lights are on but windows can't seem to recognize it as a Headset and thus not giving it sound. The problem is (from the device manager) a Error Code 43.

I tried resintalling the drivers of the keyboard and the headset but nothing worked.

Of course I have connected the 2 usb plug of the keyboard to USB3.0 and/or 2.0 ports.

 

And now I don't know what to do anymore. I'm reaching out to Corsair but maybe should I ask the manufacturer of my headset ?:confused:

 

Anyway thanks a lot for reading and have a good day/night.

Link to comment
Share on other sites

 Share

×
×
  • Create New...