Jump to content
Corsair Community

H100i V2 Buzzing noise even at low RPM


Nostalghia
 Share

Recommended Posts

Hello, so I just got this H100i V2 which I upgraded from my H105, and I'm using the Asus suite fan controller software to control this thing because I don't want to install the corsair link because the cooler USB hub thingy is so out of place.

 

I have the water pump running at 50% and there's still a buzzing sound, which is very annoying because my case is full of corsair's AF120 and SP120 quiet edition, which are very quiet so all I hear is the buzzing sound which is really annoying. I would understand if it buzzes at 100% power, but it's at 50%. Even at 30-40% there is still a slight annoying buzz.

 

It's even louder than my old H105, I got this one because it has an improved pump and it's quieter.

 

Is there a "break in" period? or should I just return and buy another one? Thanks.

 

 

Another question, do people usually keep their pump at 100%? And if so, does it buzz this loudly?

Edited by Nostalghia
Link to comment
Share on other sites

I honestly wouldn't use your motherboard to control the pump speed. I am not sure the pump is designed to run at any RPM level not specified in Corsair Link. It could be that the power you are feeding the pump is not optimal and hence the noise.

 

Try Corsair link and see if it persists. If it does, then an RMA is probably in order.

Link to comment
Share on other sites

I have the water pump running at 50% and there's still a buzzing sound

 

I am not surprised as you should not be doing this.

 

The H110iV2 needs a constant +12 volts to operate as designed and the only way you should change the pump speed is via the USB connection.

Link to comment
Share on other sites

I honestly wouldn't use your motherboard to control the pump speed. I am not sure the pump is designed to run at any RPM level not specified in Corsair Link. It could be that the power you are feeding the pump is not optimal and hence the noise.

 

Try Corsair link and see if it persists. If it does, then an RMA is probably in order.

 

Would using the Asus Suite count as using the motherboard to change things? Sorry I didn't know that.

 

EDIT; Tried with the corsair link plugged in at quiet mode and there's still a buzzing sound, its kinda annoying how this is the loudest thing on my computer :(

Edited by Nostalghia
Link to comment
Share on other sites

  • 5 months later...
 Share

×
×
  • Create New...