Jump to content
Corsair Community

USB Device Not Recognized


Recommended Posts

  • Replies 71
  • Created
  • Last Reply

I've set up a few simple lighting profiles and switched between them seeing if I could replicate the problem again and thus far it's working without a hitch. Must have just been a driver issue with the initial install, if the situation changes in the future I will inform.


Thanks for the quick response time though, it's appreciated and does not go unnoticed with me.

Link to comment
Share on other sites

The USB Device message, it will start popping up every half second or so for 5ish seconds, stop for a bit, then start doing it all over again. The lights function fine, but the message popping up like that is unbearable.


Edit: It's acting like a device is being plugged in and unplugged rapidly when it starts acting up. If I unplug the passthrough cable it works fine, no issues.

Link to comment
Share on other sites

I am receiving the same issue. I'm not sure where mine arose as I haven't narrowed it down that much, but figured I might post to see if we could come up with something common between our systems and nail this issue down. I'll be using the keyboard at work tomorrow which will be on Fedora 20, so we'll see how it performs on that OS. I'll reply with results.


Also, I have mine plugged into USB 3.0 ports, tried both front and back of case, no bueno.

Tried replugging and also have my firmware updated to the latest version.


I have a profile that does a wave effect every time a key is pressed. And regardless if I'm using the keyboard or not, it will pop up with USB Device Not Recognized sporadically, there's no method to it's madness.






Not sure how, but mine seems to have resolved itself. With absolutely no input from me, mind you. Not really sure what is going on with it then at this point. I will say, one thing unique to my system is that I have a Logitech G600 which also requires a similar tool to drive it's lighting and profiles. I don't know if they may be fighting with each other. Just thought I'd throw that out there as well.

Link to comment
Share on other sites

Tried the keyboard out on two other computers with no issues seemingly when attempting to replicate the issue. Part of the problem may be that the passthrough cable is showing up as an unknown device in Device Manager. I've uninstalled all unused keyboard, mouse, and HID devices from the machine now as well.


I give for the time being, I've done about everything reasonable I can think of aside from a clean install of Windows which I'm not about to do over a keyboard.

Link to comment
Share on other sites

I have a similar issue to Dirtius. I've updated my system specs in this post. As of right now my keyboard lighting is completely dark after I tried to activate another profile. The software is now unresponsive.


I am now going to uninstall the software and shutdown and restart my computer and then reinstall the software.

Link to comment
Share on other sites

Can you guys list the USB controllers used in your motherboards please?


Sure thing.


Using Device Manager:


"Intel® 8 Series/C220 Series USB EHCI #1 - 8C26"

"Intel® 8 Series/C220 Series USB EHCI #2 - 8C2D"

"Intel® USB 3.0 eXtensible Host Controller - 0100 (Microsoft)"


Using AIDA64 Extreme:


"Intel Lynx Point PCH - USB 2.0 EHCI Host Controller 1 [C-2]"

"Intel Lynx Point PCH - USB 2.0 EHCI Host Controller 2 [C-2]"

"Intel Lynx Point PCH - USB 3.0 xHCI Host Controller [C-2]"


I have also attached two Advanced Report files generated by the Corsair software. Advanced Report 2 is just after I have rebooted and installed the software fresh. Advanced Report is after trying to upload profiles and then the unknown device starts popping up. You can see how the Corsair device has changed its name.


The problem is very repeatable. After rebooting and reinstalling the software fresh it is working (and numlock and capslock lights work). I then select any profile and then the USB device sound occurs, the numlock and capslock lights stop changing, the exclamation mark then appears over the RGB keyboard graphic in the software with "Device Malfunction" popup, and after a minute or so the software starts crashing and exiting.


EDIT: I failed to mention I have both keyboard USB connections plugged into the USB 2.0 ports on my motherboard.

Advanced Report.txt

Advanced Report 2.txt

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...