Jump to content
Corsair Community

Possible CX500M Problem?


RhysMusique

Recommended Posts

Hey, so 6 months ago I built my PC with a CX500M powering the system.

It's never put a foot wrong until the other day...

 

I was on Skype to my friend whilst gaming, and my USB headset (Corsair Vengeance 1500) kept disconnecting and reconnecting briefly... then about an hour later my Keyboard (Corsair Raptor K50) totally disconnected, so I changed which USB ports I was using in my motherboard and everything was fine.

 

Another hour passed and my 2nd Monitor started flickering, but staying switched on, as if the input signal was weak (Possible underpowered GPU), then to top it off, my NZXT LED Case Light Cable was dimming and flickering on and off.

 

I know it isn't a motherboard problem because the LED Cable is molex straight into the PSU.

 

What would be my next move? A higher powered PSU or a replacement CX500M?

Link to comment
Share on other sites

  • Corsair Employees

All of this sounds like a motherboard problem up to the flickering case light.

 

So I would troubleshoot the easy thing first and try a different Molex on the case light.

 

Thing is... so many components in the PC use the same voltages. And your components REQUIRE a constant flow of power (although the actual load is radically varying). If the power from the power supply actually discontinued long enough for a light to flicker, there's no caps anywhere on your motherboard to maintain enough voltage long enough to keep you up and running.

 

Another thing I'd check is the reliability of your earth ground. Is the chassis properly grounded to the PSU, is the PSU properly grounded to your mains' ground, etc.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...