View Single Post
Old 12-06-2019, 04:21 PM
hatman5700 hatman5700 is offline
Registered User
hatman5700's PC Specs
Join Date: Dec 2019
Posts: 6
POST ID # = 1026550
hatman5700 Reputation: 10

Originally Posted by DevBiker View Post
Do you see the drive?
Drivers are located in the iCUE installation folder.
Thanks, trying to manually point to this driver from Device Manager to see if that works.

Originally Posted by DevBiker View Post
And, last but not least, manually updating the firmware can cause issues, especially if you put the wrong firmware on there. Where did you get the firmware file from?
Tried files from both this this forum post (this is where the youtube video I posted in an earlier post points to - it leads to this forum post) regarding firmware updating the corsair link node.

I took the steps outlined in the forum post below and followed exactly (I've done this at least 6 times at this point, because I've tried every firmware version, i.e. CLNP 0.1.46, 0.2.54, 0.2.65, 0.3.72, 0.4.94 or 0.5.104).

I felt it would be good to be able to recover to any one of the CLNP 0.1.46, 0.2.54, 0.2.65, 0.3.72, 0.4.94 or 0.5.104 firmware, so I attached a .ZIP with all the firmware versions. To change the CLNP firmware do as follows:
Download the attached
Next remove all the CLNP power.
Unplug the CLNP USB cable.
Press the button below the hole in the CLNP and keep it pressed.
Insert the CLNP USB cable.
Release the button.
The recovery loader should come up as a USB disk drive called CRP DISABLD.
Delete firmware.bin from the CRP DISABLD USB disk drive.
Copy the version of firmware.bin you wish to use to the CRP DISABLD USB disk drive.
Eject the USB disk drive.
Unplug then re-plug the USB cable.
You should now have the CLNP firmware you loaded .
Note if you have multiple CLNPs do them one at a time as they will all have the same USB serial number which is "ISP".
Note I can't guarantee this will work , but thus far most of the time it has .
Reply With Quote