Jump to content
Corsair Community

Corsair Node Pro - Not showing in Link/iCue after 1 day.


Recommended Posts

Hi all - purchased 3 ML120 fans that came with the Corsair Node Pro & fan 6-splitter. Everything worked fine on the initial plug & play, but upon my first restart my Corsair Node Pro disappeared from the Corsair Link or Icue. A few restarts later within the same day (about 4 hours) - no lights.


I've tried about a billion things and seen this issue pervade across many threads [common issue it seems]. Like many others, I also own a Corsair H110i, and this works fine in both softwares (also have corsair vengeance ram and that is working fine as well - meaning color control and fan control etc.) I'm hoping someone can help walk me through the steps to rectify this issue, I'm willing to retry all/anything to get this working again.


Here's my setup:

  • Fans: all 3 fan's 4pin connectors plugged into SYS_FAN3, SYS_FAN4, SYS_FAN5_PUMP respectively (in the bottom right corner of mobo: z390 aorus)
  • Splitter: 3 fans RGB headers into the 6 way splitter. 1st, 2nd, 3rd slots. Sata power connected. 1 3pin connector from splitter to the Corsair Node Pro (lighting channel 1)
  • Corsair Node Pro: USB b cable plugged into node pro, other 9pin connector plugged into front of mobo usb connector. Sata power connected.


I will list a bunch of relevant facts below; as well as my info from USBDeview:

  • USBDeview finds Corsair Lighting Node Pro, but it is CONNECTED = NO, and GRAY LIT (also DISABLED = NO)
  • I have tried CMOS reset, and have ensured BIOS is set to default settings
  • Fast boot is off in win10; Quick boot is off in BIOS.
  • Have uninstalled/reinstalled both Corsair Link4 and iCue a bunch, in all permutations
  • Have tried switching the USB to the header where my Corsair h110i is; does not work (however my h110i works regardless of which usb header slot it is in... I only have 2 on this mobo).
  • Have tried to follow one video where the guy uses a paper clip to hit the reset button on the Corsair Node Pro
  • I can see the fans on Aorus Smartfan5 in the Bios, and can still manipulate the speed from there - haven't messed with settings too much from here - maybe an avenue for success?
  • I just ordered a regular USB -> USB b cable to try using an external USB instead of the mobo header; am currently unable to test this until I get the cable.



Bought 3 ML120 fans yesterday, worked for the first 2 hours in corsair link & icue until I did a restart, then I couldn't see my node pro in either software, and then on the next restart no more colors (my fans spin, but no colors).

Link to comment
Share on other sites

Just to note, I've ensured my bios is updated (Did BIOS Update to version F10 for Z390 Aorus Master).

Have tried flashing firmware onto the corsair node pro, have tried CLNP-0.5.104, CLNP-0.4.94, CLNP-0.3.72 - none have worked. Basically followed the youtube video that detailed the flashing process for corsair lighting node pro (unplug sata, unplug usb, use paperclip to hit small circle hole, while pressing re-insert usb, a drive appears, delete old firmware, paste new firmware, eject drive, replug the usb, replug the satas) === nothing changes.


No lights, No apperance in Link4 or iCue

Link to comment
Share on other sites

First, you only need one of them. Preferably iCUE as Link is End-of-Life.


Second, if USBDeView doesn't see it, that means Windows doesn't see it. And iCUE won't see it. Check your USB connection; it's easy and not uncommon for it to be off-by-one pin. And the reset button puts it into bootloader mode. If it's still in bootloader mode, you'll need to fix that. Review that video for the process.


SmartFan will have no affect or impact on this.

Link to comment
Share on other sites

Will try only icue going forward.


USB header _ I've tried replug unplug swap headers unplug replug for about 8 hours so hoping I haven't consistently messed up over the 22-23 attempts, but I never say never so I'll try again and check for the plug to be correct


Regarding the video , can you break down any points of failure I might be hitting? I've flashed every bios in that zip file . Wondering however if there is a version newer than 2017?


Rgr on the smartfan

Link to comment
Share on other sites

And the reset button puts it into bootloader mode. If it's still in bootloader mode, you'll need to fix that. Review that video for the process.


Hey I wanted to chat back with you on this point specifically, and kinda goes in tandem with my question above regarding drilling into the video...


To make sure I'm on the same page - this is the video: [ame]



What step or action would put this in a state where I would be stuck in 'bootloader mode'. Also to be clear - was this the same video you were thinking of regarding the firmware update process?


I've done that process at least 8 times, because I've flashed each firmware version from the zip and then some (I've trying the 5.x version like 3-4 times, figuring the newest version would be the most appropriate) and nothing changes each time. But I'm wanting to make sure I haven't missed a step or overlooked part of the process that may cause an issue for USBDeview recognizing the NoPro again

Edited by hatman5700
Link to comment
Share on other sites

I believe I mentioned it along the way; but is there any other direct action I can take to try to resolve the Device Manager error with the USB Device: Unknown USB Device (Device Descriptor Request Failed)? <see attached>


  • This is occurring in all scenarios of plugging in the node [plugging in via mini-usb to 9pin header in BOTH headers, plugging in via mini-usb to regular USB in about 4-5 different ports (back, front, 2.0, 3.0, you name it I plugged it and tried)].
  • I've done right click > Update driver > Search automatically for updated driver software > Result: "The best drivers for your device are already installed" --- is there somewhere instead I can manually download or force driver updates?
  • I've also tried right click > Uninstall device > restart > open ICUE > settings > ICUE settings > Restart iCUEService > Result: the device re-appears in my device manager but is still in the same erroneous state: Unknown USB Device (Device Descriptor Request Failed)



Related/Unrelated troubleshooting steps:


Link to comment
Share on other sites

Do you see the drive?

Drivers are located in the iCUE installation folder.


Thanks, trying to manually point to this driver from Device Manager to see if that works.


And, last but not least, manually updating the firmware can cause issues, especially if you put the wrong firmware on there. Where did you get the firmware file from?


Tried files from both this this forum post (this is where the youtube video I posted in an earlier post points to - it leads to this forum post) regarding firmware updating the corsair link node.




I took the steps outlined in the forum post below and followed exactly (I've done this at least 6 times at this point, because I've tried every firmware version, i.e. CLNP 0.1.46, 0.2.54, 0.2.65, 0.3.72, 0.4.94 or 0.5.104).



I felt it would be good to be able to recover to any one of the CLNP 0.1.46, 0.2.54, 0.2.65, 0.3.72, 0.4.94 or 0.5.104 firmware, so I attached a .ZIP with all the firmware versions. To change the CLNP firmware do as follows:

Download the attached Corsair-CLNP-Firmware.zip.

Next remove all the CLNP power.

Unplug the CLNP USB cable.

Press the button below the hole in the CLNP and keep it pressed.

Insert the CLNP USB cable.

Release the button.

The recovery loader should come up as a USB disk drive called CRP DISABLD.

Delete firmware.bin from the CRP DISABLD USB disk drive.

Copy the version of firmware.bin you wish to use to the CRP DISABLD USB disk drive.

Eject the USB disk drive.

Unplug then re-plug the USB cable.

You should now have the CLNP firmware you loaded .

Note if you have multiple CLNPs do them one at a time as they will all have the same USB serial number which is "ISP".

Note I can't guarantee this will work , but thus far most of the time it has .

Link to comment
Share on other sites


  • Create New...