Jump to content
Corsair Community

Corsair Force 3 60GB update failed 5.05


Recommended Posts


I am running Corsair Force 3 60GB SSD with firmware 5.03. I am trying to update it to the latest version 5.05 using both software - Corsair SSD Toolbox and Corsair_FieldUpdater_v1.1. Using Corsair SSD Toolbox, it detects the firmware update, downloading it but failed to apply it. Using Corsair_FieldUpdater_v1.1, its show that update is applied but after rescan or using other tool, it still shows 5.05.

Tried with both AMD and MS controller driver on both windows 7 and 8, 64 bits. I am using 22790_fw,vic, the same number as the one that programs shows previous version.

Also tried on different port and different PCs. Also tried option "Run As Administrators" for both software on all configuration.

What I am missing/doing wrong?


Link to comment
Share on other sites

AHCI is enabled in BIOS, SSD is slow, under 100MB. Tried to fully erase it as I read in some forum and reinstall OS, the same speed. This is my 2nd SSD as the 1st one failed and got it replaced an year ago. All temp stories, pagefile and all other possible optimization did not help me.
Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...