Jump to content
Corsair Community

Force F120 Intermittent detection on Asus P6T

Recommended Posts

hello everyone,


i have compiled my complete system details herebelow and hope it would be of use. anyway, the issue i am having is the above. i have had the drive for about 6 months now and shame to say i have not had the time to seriously identify the problem nor the solution. but in a nutshell, the drive has never worked properly in the last 6 months. during the first couple of weeks when i had it, i managed to install the OS and it worked well for a couple of days and then BSOD following which it has never been able to stay detected long enough.


Primary problem

1. When cold booting drive is detected and boots into window. after about 10 minutes into OS, drive is not detected no more not even using the firmware update tool as administrator. Is also not detected with Crystal Disk.

2. Sometimes when it does stay detected long enough and I put it into standby, coming out of standby drive is detected but upon shutdown or restart drive not detected anymore even in BIOS.

3. Following any warm restarts drive is not detected in BIOS.

4. Cold starting the computer detects the drive and same problem as 1 above starts.


Solutions tried

1. Updated to Firmware 2.0

2. Updated Asus P6T bios to 1408 (latest bios)

3. Enabled BIOS AHCI option and disabled Quick Boot

4. Tried changing SATA port to different port.

5. Enabled AHCI in Windows 7 with tool from Microsoft.


even after all of the above the drive is still disappearing from both BIOS and Windows 7.


Can someone help me out please? I know for a fact that the drive is not dead since its detected long enough for me to even access some of the files inside it. So what else can be wrong???


thanks everyone.

Link to comment
Share on other sites

thanks for the info ram guy... anyway, i tried something today... had an external hdd enclosure so i plugged the drive into the external and connected it to my lappie... its recognized and there were 2 partitions one for system reserved... so using win7 i deleted both partitions and formatted them...


subsequently i tried copying and deleting files into the drive... no problems.. restart the computer and reconnect the drive it works still...


at this point i am not sure if the problem is only my computer but i am going to plug the drive in when i get home and see if it gets detected first on usb and then if possible on sata port... will keep you posted but in the meantime if you have any input, please let me know.



Link to comment
Share on other sites

general update for everyone.


following my post above i plugged the drive back into my pc at home first using the USB port and then using the sata port. now the drive works without any problems. as a matter of fact the drive has been working for almost 3 days now without any issues of detection be it in windows or bios. unfortunately it is not detected on corsair firmware software even when i run in in admin mode.


i have tried copying files and deleting, format and reformat works without any issues. standby, cold and hot start... everything works.


makes me think perhaps the problem was the way the drive is formatted in windows 7?


still strange though that it is not detected on the corsair firmware software. if anything else crops up will let everyone know.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...