Jump to content
Corsair Community

F120 partition table disappeared - fw upgrade?


Recommended Posts

I've recently bought an F120 drive.

After 2 weeks of usage i opened up my laptops lid and found the drive empty.

Tried some partition table recovery tools without any luck.

The drive still works, it was possible to create a new partition table and install the OS again.


Q1: I was wondering if this problem is firmware related. Is this a known issue, and does the 2.0 firmware solve it, or should i ask for a replacement?


I also has no idea how to update the firmware.

Intstalled windows 7 ran the update tool but is says "No drives found!". Ahci is enabled.

I even tried to connect the drive using an external USB box, in that case the update failed after a few minutes.


Q2: Any idea how a normal guy with a laptop on the lap can do this update?

Link to comment
Share on other sites

90% of the time the no drives found error is fixed by right clicking and running as Administrator, despite if your account is an administrative account or not, this was in the installation instructions. Windows 7 is really funky like this.


I'm not sure why your F120's partition table was erased but you could definitely try the new firmware 2.0 and after the upgrade I would secure erase before using the drive again.

Link to comment
Share on other sites

  • 4 months later...
  • 3 months later...


This topic is now archived and is closed to further replies.

  • Create New...