Jump to content
Corsair Community

flash voyager gtr 64gb wont read in usb drive


Recommended Posts

Help - I have about 32 gigs of info on my 64gb voyager gtr. This morning i went to eject it from my IMAC, it has not opened since on any computer.


I have tried reading the data on my PC laptop running vista, my work PC running xp, and both my IMAC and powerbook running OS X, none will read the drive. I get an message showing something like XXXU168 controller usb on the pcs and nothing on my macs, as opposed to showing the name of my thumbdrive.


I have about 99% of my data backed up, with the exception of last months work files which i desperately need. I have tried a couple data recovery programs, they do not detect anything in the USB port the drive is inserted into. A data recovery service states that I can mail them the flash drive and for a non refundable $500 they will look at it and see what can be saved. They state that I am suffering from a common flaw in these first generation devices that has yet be worked out. In all I need about 25 folders off the drive, its hard to justify $500 for it


I see from previous posts mentioning issues like mine, that you will replace the device, which is great but i need that data off mine, do you offer data recovery?




Link to comment
Share on other sites

  • Corsair Employee

I am sorry that has happened but I am sorry to say we cannot recover the data, I would suggest trying a third party or some the free ware you might find at http://www.snapfiles.com to recover the data. Short of that all we can offer would be to replace the drive.



And when you get the new drive before you start using it you will need to use the MAC to re-format the drive to prevent that from happening.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...