Jump to content
Corsair Community

Can't open corsair Voyager 8Gb usb flash


Recommended Posts

I copied some data at home on my Corsair Voyager and I didn't managed to mount the usb flash at work.

At first it mounted but Windows explored couldn't read it. I unmounted it and insreted the flash again but this time the PC didn't show any notification that there is a flash drive. I tried on several different computers, but without success. At home I couldn't open the flash drive again and I noticed that if a leave it for a longer time in the usb it gets a bit hot.


The OS-s I tried the flash on are Windows Vista, Windows 7 and Linux Ubuntu. This is the second flash drive I get from you the first one was replaced because of similar reasons, but at least last time there was a slight chance to mount the usb and on one of the successful mounts I managed to get the data I had on the flash drive. Right now I don't thing I'll manage to open the flash drive.


Also on the linux computer when I insert the flash there is no notification neither in /var/log/syslog nor in /var/log/messages. (Not sure where I should check on Windows if there is any mount attempt notifications.)


Is there something I can do to try and mount the flash drive?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...