Jump to content
Corsair Community

New PSU makes soundcard go bad


GetenJoki

Recommended Posts

Hello. I recently bought a new PSU, a Corsair TX650W and everything works very well exept one thing.. Right after the installation, when talking on skype its a high pitch noise (comming from the headphones not the psu) and it sounds like it is very poor sound quality on all jacks, including the Mic, line in, ect ect. I went back to my old psu and the high pitch noise is gone and it sounds fine.

I have no idea what to do now, should i replace the psu?

Link to comment
Share on other sites

  • Corsair Employees
If possible I would test the PSU in a different system to see if you suffer from the same audio anomalies, as this could be more possible causes than a faulty PSU. If you do not have a different system to test with, then I would remove the PSU from the case and hook it up to the system with it sitting outside of the case. Also, try disconnecting any devices that are not absolutely necessary to make sure that they are not contributing to the issue. If all else fails then Request an RMA and we will be happy to replace the unit for you.
Link to comment
Share on other sites

  • Corsair Employees
Try setting up the PSU outside of the case and see if you still get the same issues. It could be that the audio cables are not shielded well enough and are getting interference from the PSU.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...