Jump to content
Corsair Community

New system builder connectin question


jgroes

Recommended Posts

Hey all,

 

First time builder and I'm slowly putting it all together and making sense out of everything. But...

 

-My video card (diamond 4870 1GB) states to connect both 2X3-pin connectors to the PSU. I had originally thought I would connect both to either V1 or V2 (modular cables). After getting most of the components in the case I noticed that there were two hardwired PCI 2X3 connectors, which I'm assuming can be taken directly to the video card. Am I correct in this thought?

 

 

- I installed an arctic cooling accelor twin turbo on the VGA. I've read through various forums that connecting the cooler directly to the VGA can cause issues, and that connecting the cooler directly to the PSU is a better choice. The cooler comes with a small 3 and 4 pin connector. How exactly does this get connected to the PSU. My guess is to take the cooler connector and place on a 4-pin molex adapter, then that to the PSU. Again, am I correct in this thought?

 

Thanks in advance for the help..... I'm almost there.

 

Joe

Link to comment
Share on other sites

  • Corsair Employees
Hey all,

 

First time builder and I'm slowly putting it all together and making sense out of everything. But...

 

-My video card (diamond 4870 1GB) states to connect both 2X3-pin connectors to the PSU. I had originally thought I would connect both to either V1 or V2 (modular cables). After getting most of the components in the case I noticed that there were two hardwired PCI 2X3 connectors, which I'm assuming can be taken directly to the video card. Am I correct in this thought?

Yes, this is correct. Also, with your Accelero, I would suggest using the 4 pin connector/adapter you listed and connecting it directly to the PSU.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...