Jump to content
Corsair Community

HX620W cycling on/off


kxve

Recommended Posts

Recently built system, worked fine for the first 2 days then after a few auto-mated restarts after load (gaming) the system would fail to boot up altogether, instead the power will come on for a few seconds before powering down, only to repeat over and over until switched off via PSU rear switch.

 

PSU functionality test suggests PSU is working fine, the fan starts up. Multimeter readings also show normal voltages thru the 12, 5 and 3.3v rails on the 24 atx connector. (Didn't test all the rails, just one of each).

 

Tried clearing the CMOS; same issue.

Run the system outside case to eliminate shorts; same issue.

Run system switching between modules of RAM in various DIMMS; same issue.

Reseated power plugs/CPU/GPU; same issue.

 

Not sure why it worked for 2 days then this started. Not sure if its an issue with the PSU, M/b or CPU.

 

/edit

 

Tried different RAM, still same issue.

 

Multimeter returns the following stats on PSU running with just 1 CPU fan as load.

8-pin 12v ATX:

11.97v

 

24-pin ATX:

3.3: 3.34v

5: 4.94v

+12: 11.97v

-12: -11.65v <-- is that normal?

Link to comment
Share on other sites

  • Corsair Employees

You voltages look solid, even for the -12v. At this point you may want to test the PSU in a different system and see if you can duplicate the same issues.

 

Just to be on the safe side, I would recommend that you make sure you have the latest BIOS for the board, and then load setup defaults in the BIOS and see if you still have problems.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...