Jump to content
Corsair Community

4 gb installed, bios only sees 3 gb


Recommended Posts

I tried switching/swapping my memory with all the different slots and I've determined all the slots and each memory stick works.. I have no idea what's the problem


I recently upgraded memory and saw this problem. running 2 x 1 GB sticks of..


I was using CM2x1024-6400


XMS2-6400 memory


(XMS6405 v 4.1) 800mhz



recently added.. 2 x 1 GB sticks of..




XMS2-6400 memory


** (1.90 v. ver. 5.2) 800 mhz



almost exactly the same except the new one is a slightly newer version?


I thought one stick was bad so I switched them around and they all work (unless I made an error). And I tried each individual slot and they all worked too. Never had any startup problems or anything like that.



However, when installing all 4, my bios only reads 3 gb and the last one does not register.


I realize windows XP pro will only recognize 2.96 or something, but my bios doesn't detect it and that worries me.



Ran memtest and it found no problems (though I only ran it for like 15-20 min)


My mobo is an ASUS P5B

Link to comment
Share on other sites

Let Memtest run longer as it wouldnt have even completed one pass. It really sounds like a bad DIMM slot but you said you tested that. Try one of the modules that you know works in each slot seperately. See if the PC will boot in all slots.

You are correct, a 32 Bit OS wont detect all of it but you BIOS should. Try updating to the latest BIOS if you dont have them already.

Link to comment
Share on other sites

Enter your BIOS and set the "Memory Remap Feature" to enabled.




The BIOS should read the 4GB. Keep in mind that if you are using a 32bit OS such as Windows XP 32bit or VISTA 32Bit, you will not see the entire 4GB and will likely only see ~3.2GB or so due to the system resource DRAM addressing, hardware DRAM addressing and overhead. Since the maximum address space in a 32bit OS is 4GB, you will lose some for all the components that require addressing space in this area.

Link to comment
Share on other sites

I did as you said DerekT and it worked! When I rebooted the bios showed 4 gigs.


What's weird however, is that after making those changes in the bios, windows now only sees 2gb of RAM and not 2.96 like before... weird


should I switch it back? haha


at least I know everything works... which was my main concern

Link to comment
Share on other sites

How much memory is shown in http://www.memtest.org.



Here are the stats:


Intel Core 2 (2394 mhz) should be dual core 2.66 mhz?


L1 cache: 64K 39253 mb/s


L2 cache: 4096K 16744 mb/s


memory: 4095m 4072 mb/s


wall time 12 hrs


cached 4095m


rsvd mem 444k


memmap e820-std


cache on


ecc off


test std


pass 15


errors 0


ecc errs blank




everything look ok? processor showing up normally..? dunno exactly how to interpret data. looks like its reading all the memory.


any solutions for a windows fix? or anything to get it reading the max winxp pro can show?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...