Jump to content
Corsair Community

Flash Voyager 4GB - Write Protect Error


Recommended Posts

My 4GB Flash Voyager has a "Write Protect Error" around the 1GB mark when I am copying across large files (around 500MB-1.2GB each). The error in the System Event Viewer is:


Source: Fastfat

Event ID: 50

Type: Warning


Description: {Delayed Write Failed} Windows was unable to save all the data for the file . The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.


I've tried re-formatting it as described elsewhere on these forums with the supplied Flash Utility, EzRecover, & DiskManager with no luck, though it completes the format perfectly each time. It also completes fine with any combination of FS type and allocation size as well.


I have found that I can fill the 4GB with 100MB files without an error. To further diagnose my dilemma, I ran 'chkdsk' when it was full of 100MB files, and in the System Event Viewer I found the hundreds of the following event:


Source: Disk

Event ID: 7

Type: Error


Description: The device, \Device\Harddisk2\D, has a bad block.


Also, CheckDisk reported that the device had "2,359,296 bytes in bad sectors" which were fixed, but if I format, fill and 'chkdsk'it again it reports bad sectors every time.


What can I do from here? Is a replacement an option?


Thanks for your help in advance!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...