Jump to content
Corsair Community

GA-K8NS Corsair Value Ram


Recommended Posts

Okay, so you may remember that I posted a while back regarding my new stick of 184 pin PC3200 512mB RAM. It wouldn't work with my existing stick...so...I got another one of the exact same type. I've double-checked in every way that they are the exact same (ordered from the same NewEgg page, same product code on the sticker, etc.)


When I put them both in the computer, it turns on, but it won't post or anything...no video feed either. After that, when only one (either one) was in the computer still did the same thing. I opened the case, double-checked all the connections, and tried to boot again. This time, it wouldn't even turn on. So I tested connections, tried again, etc., until I finally got it to boot properly. I have no idea waht the problem is, or if it has to do with the RAM. (NOTE: I never have this problem unless I try to put new RAM in.)


Thanks in advance.

Link to comment
Share on other sites

  • Corsair Employee

That might suggest a power problem, but I have no problem replacing the modules for you if you want to try that.

Please follow the link in my signature “I think I have a bad part! Or *New* Tech Support Express” and we will be happy to replace them or it!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...