Jump to content
Corsair Community

512mb Flash Voyager Problems


Recommended Posts

I recently purchased the Corsair 512mb Flash Voyager memory drive.


My problem is that it doesn't work on my machine. I am running Windows XP Service Pack 2, my Windows is fully up to date, and I can't seem to find out what the problem is. The device is found by Windows as a 'USB Embedded Hub' and I am then asked to install the software by the Windows Wizard. But after searching for the drivers, none can be found. The device doesn't come up as a driver in 'My Computer'.


What is annoying the hell out of me is that when I took the memory drive back to the shop, they tested it on their machines in the back and it worked perfectly, they even showed me. It also works at my University, but it doesn't work on my home PC. Therefore the shop will not exchange the drive or offer me a refund because to them the device isn't faulty.


Another thing is that all other USB devices work fine on my machine, I have my printer, mouse, bluetooth dongle that are connected through USB, as well as an MP3 player. Other family members USB Memory Drives work perfectly too (generic ones).


I have already emailed Ramguy, but I thought I might as well post as well, in case anyone here as had the same problem, maybe they know how to fix it?


Desperately need help lol!!

Link to comment
Share on other sites

It's an ASUS A7V600 motherboard.


I'm using the USB port directly off the back of the Motherboard. I've tried it on the back of my tower and on the front USB ports.


My system spec is,


AMD Athlon XP 2800+ (running at 2.24ghz)


1GB Ram

Link to comment
Share on other sites

  • Corsair Employees

Sorry but no, if the drive works in other systems but not this one there is either a hardware failure on the MB or some issue with the driver for your MB and or chipset.

Will the flash drive work in another system?

Link to comment
Share on other sites

Yes, at their shop and at my University.


But I dont know why it doesnt work on my MB!! There are no problems with the MB at all, all OTHER USB devices work perfectly, even other pen drives that I've tried.


It just isnt compatible with my system.:confused:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...