Jump to content
Corsair Community

Vengeance RGB Pro Not Detected by iCue + Stuck with red light on tips

Recommended Posts

Need any help at all at my wits end.

Been struggling trying to trouble shoot my ram for the longest time I've had it the iCue lights never worked consistently. I decided to reach out to corsair support to try to remedy the issue and eventually they determined that they would just send out a new set of RAM. I replaced the RAM and the same exact issue was occurring of the lights being stuck on permanently red on the tips and iCue not detecting it at all. iCue is able to pick up on the RAM thru all of the monitoring also, just iCue can't functionally modify it.

As far as I can tell the lights being stuck on is a sign that the RAM is stuck in firmware update mode or it has conflicting RGB controller software. 

I've tried a myriad of troubleshooting to no avail.

  1. Running armoury crate uninstall
  2. Updating BIOS to latest version
  3. Enabling SPD write thru BIOS
  4. Reinstallation of iCue 4 and 5
  5. Turning Aura off in BIOS
  6. Forcing every update on the iCue software
  7. Running iCue repair
  8. Reseating memory modules in every configuration possible
  9. Replacing the memory modules with the set that Corsair RMA'd for me


If anyone has any idea what to try next or if I should just buy some G.skill instead please let me know!

Edited by maddieg
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...