Jump to content
Corsair Community

iCUE update messed up after update.


Recommended Posts

So I updated my software yesterday and well since then it has not worked right.

1. My Virtuoso SE headset will not show on the program and unable to reconnect it iCUE.

2. The software will shut down after 2-3 minutes and the RGB will go back to default.

3. Settings do not save and RGBs on RAM freeze.

I have reinstalled(included REGEDIT) and I have done the modify/repair and those do not work either.

Is there a known issue with this update? If so how can I revert this to a known working patch.

Accessories are:

Virtuoso SE Headset

H100I Elite LCD

Vengeance RGB Pro x 4

Nightsword RGB Mouse

K100 RGB

Link to comment
Share on other sites

  • Corsair Employees

We would recommend that you perform the clean uninstall and install instructions in the link below. If that does not resolve the issues reach out to our support team directly by opening a ticket at http://help.corsair.com

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

Link to comment
Share on other sites

9 minutes ago, Corsair Notepad said:

We would recommend that you perform the clean uninstall and install instructions in the link below. If that does not resolve the issues reach out to our support team directly by opening a ticket at http://help.corsair.com

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

I have done both already. id #2005294687

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...