Jump to content
Corsair Community

HS60 Pro surround not working


Recommended Posts

My HS60 Pro suddenly stopped working in the middle of playing Enlisted, and when plugged in Windows registers that it's plugged in, icue recognizes it too, but volume is stuck at 100 even though nothing is coming out of it for sound and the mic also isn't working like this. I have tried uninstalling all my audio drivers, a system restore, and since there is no option to force a firmware update via icue as I saw suggested elsewhere. I've tried plugging it in via the adapter it came with and I have been using since I got it into several different USB ports on my computer as well. I have no idea what to do to fix this and I don't have a back up pair of headsets to use either in the mean time. If ANYONE knows a fix for this please tell me because I'm completely lost on this issue and would like it help sooner than later.

 

 

Link to comment
Share on other sites

  • Corsair Employees

Hi,

Attempt to repair the iCUE software.

 

Control Panel

Programs and Features

Right Click the iCUE software

Select Repair

Restart computer,

 

Can you also check to see if the issue persist if you use  the 3.5mm cable only?

Let me know if the you still have issues.

Link to comment
Share on other sites

On 3/24/2022 at 12:22 PM, Corsair Elito said:

Hi,

Attempt to repair the iCUE software.

 

Control Panel

Programs and Features

Right Click the iCUE software

Select Repair

Restart computer,

 

Can you also check to see if the issue persist if you use  the 3.5mm cable only?

Let me know if the you still have issues.

the issue is still around after the repair and restart, but is not with only the 3.5mm cable, the issue with the 3.5mm however is I cannot have the headset act as both headphones and a microphone as it's supposed to.

Link to comment
Share on other sites

  • Corsair Employees

You may want to look into a replacement mic, it may be a hardware issue.

Remove the mic and plug it into you AUX jack by itself, and check if the mix is detected and working.

If it works, there's likely and issue with the headset or the dongle, if the mic doesn't work you may need a replacement mic.

Contact Support @ https://help.corsair.com/hc/en-us

They can help you with this issue.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...