Jump to content
Corsair Community

HARPOON RGB WIRELESS MOUSE NOT WORKING AFTER DONGLE UPDATE v.5.5.112


Recommended Posts

I updated my HARPOON WIRELESS RECEIVER firmware to v.5.5.112 and my mouse stopped working whatsoever. It doesn't show up in the iCue app if I plug it in or not it doesn't matter therefore I can't update the mouse firmware. And i can't even connect it via bluetooth to my PC.

Link to comment
Share on other sites

I have exacty the same issue. I got my mouse new today and just by doing the firmware update seemed to have screwed it all up. Very annoying.. I am only able to connect my mouse now via bluetooth and not via 2,4ghz.. Does anyone PLEASE already know a fix??

Link to comment
Share on other sites

  • 2 months later...
  • Corsair Employees
9 hours ago, deepeezee said:

I just had the exact same issue. Did anyone find a fix for this? Have created a ticket with support too (ticket #2005292040)
Can anyone from Corsair help?

You have already done the correct thing by creating the support ticket and our support team will be able to assist you there.

Link to comment
Share on other sites

On 5/19/2022 at 9:41 PM, Corsair Notepad said:

You have already done the correct thing by creating the support ticket and our support team will be able to assist you there.

It's been 3 days already, no response on the ticket. Anyway to get the right firmware file for the USB Receiver?

Link to comment
Share on other sites

I just purchased this mouse yesterday. Upon install, I was immediately prompted to update firmware for both the mouse and dongle. I successfully used the mouse in all modes after the updates. Rebooted this morning and upon login, I unplugged the mouse to find it wouldn't function in either non-corded modes.

I also did a force firmware update for the dongle in iCue, which also had no effect.

The only thing I find in device manager as a Corsair composite virtual input device is a virtual device under Human interface Devices & Corsair bus under System Devices. This is not OK.

Link to comment
Share on other sites

  • 3 weeks later...

I Also bought the harpoon today and worked perfectly untill, icue ask for updating the receiver and the harpoon mouse.
I updated the firmware for the mouse and receiver and after the update the mouse is not working wireless on the 2.4 ghz band.

The mouse only works with the cable or on bleutooth.

Link to comment
Share on other sites

Same here, just got my brand new Harpoon Wireless, updated the ICUE software and both firmwares (Mouse: 5.0.129 and Dongle: 5.5.112) and it never worked over 2.4G. Seems that OFF and 2.4G both are making the mouse OFF.

Please help. Works only over cable or bluetooth.

Link to comment
Share on other sites

  • 2 weeks later...

Same for me, after firmware update the mouse is connecting over 2.4GHz or usb cable to a Macbook Pro (bluetooth works tho) and doesn't show up in iCue. No answer for support ticket yet (after 3 days).

Link to comment
Share on other sites

I have contacted the support desk and they gave me a walkaround and send me 2 files to downgrade the firmware. I did the walkaround and downgraded the firmware but neither the walkaround or the downgrade helped, the files they send were not compatible. I have that same issues with the virtuouso SE headset. They bring out an update but i think that they did not test it properly and just shove it down.

Link to comment
Share on other sites

Got answer from support but it seems they haven't even heard about the problem. The guy asked me to not use a hub (never did) and explained how to soft reset the mouse (tried it many times before I've sent the ticket) and asked me to connect the mouse over usb cable if non of the above worked. I clearly explained in the ticket that the mouse is not working over usb cable only on bluetooth, so it seems this was just a usual copy-paste answer.

I guess either the firmware of the dongle has a major bug or the update just bricked the mouse, since it not even shows up as a usb device anymore but everything worked before the firmware update.

At least for me the bluetooth mode is OK so far.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...