Jump to content
Corsair Community

Windows ME USB Driver not Loading


Recommended Posts

Product: Corsair Flash Voyager 1 GB

I have 2 systems

Works well in Windows XP Home Box.


Drive is recognized by my Windows ME system but says

"the ntkern.vxd device loaderfor this device could not load the device driver"

I tried to update driver to no avail. Says "the best driver is already installed"

but I still cant see the drive in "MY Computer"

This is a POS Compaq with no OS disk just the factory setting restore disks.

so I do not have access to the Windows Drivers for this new USB flash drive.

Any suggestions?


Oh, I tried the voyager at work and as soon as I plugged it in it was recognized, and I was able to view contents and copy them over fine.

Just as a good plug and play device should. Worked great at work.

Just this darn ME system giving me trouble.

I really bought this to save financial info from this ME system so I would not have to rely on floppy disk.

Help Please.

Link to comment
Share on other sites

  • Corsair Employees

Please try with the USN drive installed in the system to remove the unknow/non working device and then remove the USB devices listed removing the HUB as the last thing. Then you should get the latest USB Update from Microsoft and run the install.


There is also a wealth of information on the Web about this subject like at http://www.usbman.com Link to this question or close to this question.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...