Jump to content
Corsair Community

dead 3200XLPRO

Recommended Posts

I'm pretty sure I have a dead pair of ram. I jus built my third system and it's based on the SLI-DR. I used to use the XLPRO on my asus board but I transferred them to my DFI. Everything was all fine and stable until I changed the heatsinks of my DFI from stock to a Thermaltake. Everything was fine and stable till I changed the heatsink. The system would boot up and resume windows then after that it just shuts off. I could not figure it out why till I looked carefully on the bios settings. The temperature shutoff was enabled at 65 so whenever the board reaches 65 tempt it would shut off. This happened four times till I figured it out and that I think killed my ram. I have tried my Crucial rams on the DFI and the system is fine. I tried the XLPRO on my asus board and it does not boot up. And that is why I think my XLPRO is dead. Can I RMA them?
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...