Jump to content
Corsair Community

Corsair Mouse, Lift and place down left click Fix


Recommended Posts

Hello,

Short story, In your mouse options in ICUE, Turn off "Enable Button Response Optimization" in Surface Calibration (I use Icue 4)

 

Long story,

So I had a few Gaming mice, all from Corsair in the past and even now.

I have the Iron claw, Iron Claw wireless, Dark core and now the Saber Pro Champ edition. I noticed when I moved to Icue 4, my mice started to left click on its own when I would lift the mouse up and place it down ever so slightly while gaming. Annoying during gaming because it pretty much cancels out your movement when it left clicks on its own as you adjust the mouse due to space. Imaging playing an FPS like this!

The reason I am making this thread is because I have read a few other threads on here and reddit without answers with the same issue. Some mods even telling users to exchange the mouse as this is not normal behavior. It isn't. Please have the support team report this as a bug in their Icue software. Turning this option off prevents this from happening. Until it's clear to everyone, it is considered a bug and should be looked into as I am sure it's costing Corsair and other companies money in returns due a simple option.

Hope this helps anyone that is experiencing this issue without an answer. None of my Mice are showing symptoms when this option is turned off.

Let me know if this helped you.

Link to comment
Share on other sites

  • 2 weeks later...

not seeing this setting with a dark core pro RGB SE on icue 4.11.274.

Having issues with slam clicking predominantly on the right click when lifting off and resetting mouse position. left click does it too, but i have to put the mouse down with some force to trigger that. Im not sure if it is a hardware issue and just bad QC, or a design issue, or worse yet, poor software, but as it stands, my mouse is a lemon :(

Link to comment
Share on other sites

so i recievied my replacement dark core pro RGB SE today, and it has the exact same problem as my initial one. I dont see any button response optimisation settings, and considering this is the 2nd mouse in a row with the issue, and my friend who just also purchased the mouse is also having the same issue, and looking at returning, what are the chances there is a bad batch or some form of software related issue? its incredibly frustrating, as i really dont want another mouse, but i cannot use it as it is. im tempted to replace the switches myself to a higher weighted omron, but id rather not trash my warranty.
Link to comment
Share on other sites

  • 2 weeks later...
  • 6 months later...

I noticed that same issue playing FPS while running and turning my gun would shoot on its own. i thought i was hitting the mouse button and not noticing it. but it has happened SO many times. i ran troubleshooting on it. reinstalled software. and it still does it. i dont have those setting turned on so. they are off on mine. angle snapping is off, and button response optimization is off also. so it must be a more series problem with this mouse and its software. ive had this mouse for about 3 or 4 months now. now im already having to look for another do to this stupid glitch. im just glad im not the only one who has this issue i thought i was going crazy. gun keeps shooting on its own. lol  

SABRE RGB PRO CHAMPION SERIES 

Edited by 1976_Greygoose
Link to comment
Share on other sites

  • 1 month later...
On 5/12/2021 at 12:28 AM, Gigz said:

Hello,

Short story, In your mouse options in ICUE, Turn off "Enable Button Response Optimization" in Surface Calibration (I use Icue 4)

 

Long story,

So I had a few Gaming mice, all from Corsair in the past and even now.

I have the Iron claw, Iron Claw wireless, Dark core and now the Saber Pro Champ edition. I noticed when I moved to Icue 4, my mice started to left click on its own when I would lift the mouse up and place it down ever so slightly while gaming. Annoying during gaming because it pretty much cancels out your movement when it left clicks on its own as you adjust the mouse due to space. Imaging playing an FPS like this!

The reason I am making this thread is because I have read a few other threads on here and reddit without answers with the same issue. Some mods even telling users to exchange the mouse as this is not normal behavior. It isn't. Please have the support team report this as a bug in their Icue software. Turning this option off prevents this from happening. Until it's clear to everyone, it is considered a bug and should be looked into as I am sure it's costing Corsair and other companies money in returns due a simple option.

Hope this helps anyone that is experiencing this issue without an answer. None of my Mice are showing symptoms when this option is turned off.

Let me know if this helped you.

Thank you this helped me with my issue.

I just wanted to add that the option now is in the device settings and not in the Surface Calibration.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...