Jump to content
Corsair Community

CRP Disabled


twest
 Share

Recommended Posts

Hello I updated firmware on two products today and both are non-responsive and giving me a CRP disabled window with the firmware.bin

 

Dark Core RGB Wireless

and K63 Wireless

 

Never had any firmware issues until today.

Link to comment
Share on other sites

Hi guys, since yesterday i got dead dark core mouse after tentative to update the firmware to the latest version as suggested by ICUE software.

The mouse is apparently dead ( but it's not actually cause it goes in CRP DIASABLED mode) I tried the soft reset procedure as described on ur site but nothing changes.

I submitted the ticket as i read that u email the firmaware and instructions to overcome this awful situation, I'm a little streamer and now I m forced to use a secondary (very cheap but working) mouse, and this is an actual living hell for me, the ticket seemingly takes up to 4 working days to be answered, I need the fix quicker, how can we do it?

I almost never had firmware issues, just 1 time with the K63 keybord but in that case the soft reset procedure worked fine but not this time with dark core mouse.

For the future I think that it would be a good idea to post the firmaware on the download section of ur site, cause having to wait up to 4 days for fixing a software generated issue is not that great.

I really like ur products, and I got lot of them, dont make me change my mind.

 

Kind Regards

Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...