Jump to content
Corsair Community

H100i V2 Extreme default pump curve


gothicaholic
 Share

Recommended Posts

So I was wondering, I was running my H100i V2 Extreme pump on the default CPU_FAN setting and it was set to a climbing curve obviously, and lately the pump been making buzzing noises.

 

Is it possible for that default curve on the CPU_FAN has damaged the pump? To be noted pump still runs fine 1850 - 1950 RPM on the quiet setting in iCUE and temps seem to be fine with the usual tiny spikes.

Link to comment
Share on other sites

No, if your pump starts to make noise or otherwise act weird at the Extreme/Performance higher setting — it’s not your fault. That pump would have done the same thing on the lower speed sooner or later. Unfortunately the pump is an electro-mechanical part and the component most likely to have a physical problem. Buzzing is a common complaint and usually electrical rather than mechanical, so it is not the number of revolutions that mattered.

 

Keep using it on the lower speed. There shouldn’t be much difference in performance. If the noise finds its way there too, contact Corsair or look at your options. Don’t live with the buzzy pump. It’s too annoying and every time I have let it go, I regretted the headaches in the interim.

Link to comment
Share on other sites

No, if your pump starts to make noise or otherwise act weird at the Extreme/Performance higher setting — it’s not your fault. That pump would have done the same thing on the lower speed sooner or later. Unfortunately the pump is an electro-mechanical part and the component most likely to have a physical problem. Buzzing is a common complaint and usually electrical rather than mechanical, so it is not the number of revolutions that mattered.

 

Keep using it on the lower speed. There shouldn’t be much difference in performance. If the noise finds its way there too, contact Corsair or look at your options. Don’t live with the buzzy pump. It’s too annoying and every time I have let it go, I regretted the headaches in the interim.

 

It is there even on Quiet 80% CPU_FAN, I dont mind the noise as my radiator fans are running at a custom curve and they are already noisy, I am just concerned about the electrical unstable buzzing that it emits once I fire up a game, no real performance issues with it, just electrical noise.

Link to comment
Share on other sites

Oh, so you are already throttling the voltage to the entire cooler? The H100i v2 gets its power from that MB header. It is effectively like turning a dimmer switch on the entire device - pump, fans, LED. This probably has a negative effect on longevity, but perhaps that is not the concern. It certainly will alter your fan speeds.

 

People have been cutting voltage to the pump for a long time. Be aware - this is not a permanent solution. The buzzing will find its way to you again. You will cut more voltage. The process repeats. You wind up with 2/3 of a cooler. As most coolers are SATA powered these days it is no longer a frequent topic of discussion, but this is a slippery slope.

Link to comment
Share on other sites

 Share

×
×
  • Create New...