Jump to content
Corsair Community

[iOS 13.2] Corsair Harpoon RGB Wireless - can't connect via BT in iOS/iPadOS


Recommended Posts

Hey there everyone,

 

For some reason, my Harpoon won't connect to my iPad when put in BT mode. iPadOS does support external pointing devices since iOS13. For this, you're supposed to:

 

Go to Accessibility

 

Go on to "Switch-Control"

 

Further into "Switches", you shall see "Bluetooth-devices" (just beneath "Add-new-switch....) and tap on it.

 

Other BT devices are listed, my Harpoon isn't. It doesn work in wired mode and BT does work on my PC as expected.

 

Is this a FW issue? I did try to force the latest BT firmware onto my mouse, but nothing has changed.

 

Would appreciate some feedback, as I got this mouse as a jack of all trades sorta device.

Link to comment
Share on other sites

  • 5 months later...

Hi, I think I am having the same problem as you.

 

I just bought this Harpoon RGB Wireless because the connectivity options, but I it seems that it does not work at all with IPadOS 13.4. I mean, the mouse is able to pair with the iPadOS, however it does not work, the cursor does not shows up. It is not an IPad issue though. I have a Logitech mouse that works well both versions, iOS (13.2) and iPadOS (13.4).

 

I would appreciate any feedback on this topic. Thanks.

Edited by crazytrain
Link to comment
Share on other sites

  • 4 weeks later...

Same here. Bought the Harpoon RGB wireless about a week ago because of the connectivity options and it doesn't work on my iPad Pro 2018. I don't want to return it because I really like it but this is a real bummer.

 

Any update would be appreciated.

Link to comment
Share on other sites

  • 3 months later...
  • 4 months later...

I'm on iPadOS 14.3 with full mouse support, and this mouse still doesn't work.

 

Fine, I can accept that it might not be compatible. My question is - why is this not mentioned on the product page? I bought this mouse specifically because I wanted to use a device on both PC and iPad, and this is what I'm hit with.

 

A simple list of supported OSes would've sufficed. And seems like iPadOS is the only one that's not supported, are the any plans to support this mouse in the future?

 

I can see it listed under the Connected Devices tab in the iPad's AssistiveTouch options, but there is no cursor and none of the buttons on the mouse work.

 

Do better, Corsair. I'll have to return this product which is a shame because I absolutely love the mouse on my PC.

Link to comment
Share on other sites

  • 1 month later...

Agreed. I chose this mouse over Logitech just because it had Bluetooth support that I need for my iPad. I don’t see any reason why it would be incompatible as the most basic bluetooth mouses do work with it. It seems like Corsair is specifically blocking this capability. It should state on the packaging that it is not compatible with iPad OS. The technical sheet is misguiding as it states that the mouse has Bluetooth support, which it doesn’t really.

After trying to contact them I was answered by different people every time who just asked the same questions over and over again and didn’t seem competent of solving the issue. I was not provided with the information whether I am eligible for a refund since the product doesn’t function as advertised. Very dissapointed.

Link to comment
Share on other sites

  • 3 months later...

Resolved from this tutorial => https://help.corsair.com/...

 

Resetting Your Wireless Computer Mouse

If you have a wireless computer mouse, the resetting steps are slightly different from resetting a wired computer mouse.

 

To reset a wireless mouse:

 

Turn off your wireless mouse.

Hold down the left and right mouse buttons.

While holding down the mouse buttons, turn the mouse back on.

After about 5 seconds, release the buttons. If the reset was successful, an LED flashes.

Link to comment
Share on other sites

  • 2 months later...

I just bought the mouse and have the exactly same issue,I bought it for muti-devices use(between PC and IPad)

It doesn't work via BT in IPadOS, connected via BT but unable to use the mouse via BT.

The mouse does work via cable or 2.4GHz SLIPSTREAM in IPadOS.

Even I tried to reset the mouse,still have some issue.

so bad 

Link to comment
Share on other sites

  • 3 weeks later...
  • Corsair Employees

The mouse is not compatible with iOS and therefore will not work with your iPad.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...