Jump to content
Corsair Community

1.16.42 with Scimitar Pro? Cue 2.11.15 Problems... :(


Recommended Posts

I am having no end of problems with CUE 2.11.115. I am not convinced it is even installing correctly in Win10 x64. I get no tray icon and no background splash image when CUE loads. Clean installs with no background processes running. Mouse is on firmware 1.10 with cleared on-board storage.


To add to that the mouse is misbehaving by randomly profile switching (or at least switching to some default setting) mid-game, colour settings randomly stopping (defaulting to rainbow from static configuration) and very occasional momentary freezes.


Does 1.16.42 support the Scimitar Pro? I can't seem to find a firm answer on that. If so, I'll just abandon CUE2.x for the time being as my use case is nothing particularly fancy. I just want a side grid with flawless sensor and the Scimitar Pro delivers - but not if I can't get the silly thing working reliably.



Link to comment
Share on other sites



So any suggested fixes to my problems? I have tried the previous two CUE2.x versions and same result. They don't appear to install correctly with no tray icon or background splash image. Presumably the issues with actual mouse performance would re-appear as well, but I reverted to 2.11.115.


One of the things I had done was reconfigure the profile hardware button to a keyboard key via a software profile as I use it for PTT voice comms. I had also deleted/cleared the onboard storage. Could that be causing issues and making CUE think I want to change profiles?


Instead this time I have created three identical hardware profiles (differing only in static lighting colours) mapped to each on-board storage slot, so if the problems are arising from CUE not liking the profile button re-mapped in a software profile, I may get a better indication based on what the lighting does.

Link to comment
Share on other sites

The tray icon is active, it just has no image:





By splash, I actually just mean the background image of the main screen - it is just white. If I tick the blur background image button, it changes to just being black.




System specs:

Intel i7 3770

Gigabyte Z77X-D3H

G.Skill 32Gb (4 x 8Gb DDR3 9-9-9-24)


256Gb SSD OS drive with various additional SSD and Magnetic

3 x 27" 1080p Monitors

Win10 x64

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...