The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   K70 MK.2 Low Profile Rapidfire not recognized by iCUE 25%+ of the time. (https://forum.corsair.com/forums/showthread.php?t=189481)

vulcan78 08-11-2019 09:56 AM

K70 MK.2 Low Profile Rapidfire not recognized by iCUE 25%+ of the time.
 
Yeah, it did it again this morning, when the PC starts it doesn't recognize the keyboard and the profile isn't launched and the iCUE task-bar icon is a red circle with white exclamation mark and if you open iCUE it says that no Corsair keyboard is connected.

This is becoming a problem that is now happening on a weekly or more basis. The last time it happened was 5 days ago.

Restarting the PC doesn't resolve the problem (I just restarted it 3 times in a row and lost my entire previous Chrome session in the process, hence being pretty ****ing pissed and feeling the urge to write this here)

Only completely powering off the PC via PSU for 30 seconds resolves the issue (or physically disconnecting and reconnecting TWO USB cables, if I do this on a weekly basis I'm afraid of damaging the USB ports).

This makes for a 10 minute affair first thing in the morning? Yeah not happy.

Apophis3 08-11-2019 12:28 PM

Fast Boot can cause drivers to not initialize properly, and cause issues. (Essentially your PC is waking from hibernation) Disable this and see how it goes.

vulcan78 08-12-2019 01:42 AM

Quote:

Originally Posted by Apophis3 (Post 1014373)
Fast Boot can cause drivers to not initialize properly, and cause issues. (Essentially your PC is waking from hibernation) Disable this and see how it goes.

Ok thanks for the advice, I may try that, it's jus that this is the only USB peripheral exhibiting the problem, so I figured it was an issue with iCUE not fast boot.


All times are GMT -4. The time now is 08:04 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.