Jump to content
Corsair Community

Recommended Posts

So i recently bought an M60 mouse, super excited when it appeared at my doorstep. Unboxed it, plugged it in to my laptop, saw the led backlights go on... and thats it. No prompt for firmware/driver/software install, no notice of a new device connected, and more importantly, no response from mouse at all. I have tried plugging into all 3 of my 2.0 ports and my 3.0, and on another laptop with the same result. It will not appear in devices or hardware manager and all my usb drivers are up to date. I have tried downloading the firmware updater off of the product page but could not even proceed to install because it needed the mouse to be plugged in to update... which it is, but there is no such indication. Is there anything I can do to remedy this? (step by step would be appreciated because i tend to get lost easy)

Additional notes: all other devices work fine (external HDD, wireless mouse, controller etc.). I have searched high and low for a solution but havnt found any that work for my issue, all involve driver updates or firmware... but i cant get that far. I have emailed both corsair and the site I ordered from and called to set up a return/exchange if nothing can be done. System specs are not listed because I just use an acer aspire laptop (working towards a proper pc) but i use windows 7 home premium 64 bit.


Please help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...