Jump to content
Corsair Community

Can't update to 5.03


Recommended Posts

Hello guys.


Ok, maybe this is another of thousands of topics already asking why someone can't update to 5.03. Ok, I've already read several posts around here before. I just can't make it work. The Corsair FieldUpdater is not updating my SSD.


First things first. I'm having BSOD all around using a Corsair SSD Force GT 240g (signture 22956). But this topic is not to help me with it. I'm just trying to isolate the problem, so I'm trying first to update the firmware.


What I'm doing:


  • I plugged my SSD on my desktop PC (the ssd was originally installed on my notebook).

  • Then I applied the AHCI update from MS site. Also checked on regedit to see if the update properly changed the registry.

  • Then I downloaded from this forum the Corsair_FieldUpdater.exe to make the updates and the 22956_fw.vic for the new firmware.

  • Used the step by step pdf guide and I tried to update the firmware. After the update (around 30 secs), I get the green check icon on my SSD. But when I click "rescan", my ssd is still 5.02.


Any ideas?


Thanks in advance for any help.

Link to comment
Share on other sites

Have you tried a different SATA data cable and port?

Have you tried using the MSAHCI drivers and the Intel chipset ones?


Yep, tried on another port and using another cable. I tried also using another machine. Can get the fiwmware to update!


Now, about these MSAHCI drivers you asked about, I don't know anything about it. Can you please advise me?


Thanks again for your help guys!

Link to comment
Share on other sites

  • 2 years later...


This topic is now archived and is closed to further replies.

  • Create New...