Jump to content
Corsair Community

h80i wont start. Broken?


Recommended Posts

I just changed my chassis and moved all my components over to the new one. At the same time I changed the stock-cooler (Intel) to Corsair h80i.


After I had moved all the components and mounted the radiator and CPU-cooler, as well as connecting all the necessary cables to the cooler (CPU-fan as well as power from the PSU) it was time to start up the system.


When I started the computer it started up for like 5 seconds. After that it just rebooted and started up for 5 seconds agan, and looped like that without getting anywhere...Everything starts up (gfx, fans on the chassis etc).


When I checked the CPU-cooler I noticed that the corsair emblem, which is supposed to have a blue LED-light is completely dark.

My suspicion is that the h80i is not working, although I am not fully sure on this, I do not know how to check if it is starting else than checking that the LED is on on the CPU-cooler.


What I have done:

- I have tested to connect another unit to the PSU to check if it is working just to see if there was any problems with the powersupply to the corsair - the unit worked fine.

- I have tested every fan-conector (including CPU-fanconnector) on the motherboard. All work.

- Every cable from the PSU (2x4-pins to CPU as well as 24-pins to motherboard) is attached.

- I have tested to reset the CMOS on the mobo.

- I will test to mount the original CPU-cooler when I get home to work...


Nothing seem to work, and im out of ideas? Is the h80i broken or is it something else? Should I RMA?

Or has anything else broken when I moved the components from on chassis to another?


Grateful for all the help that I can get in this issue!



Link to comment
Share on other sites

Did you make sure you have it plugged into the PSu. And once you start your computer, see if you can get into the BIOS and see what the Pumps RPM is. It will be the CPU_FAN header if thats where you plugged the single wire into




Yes, I have checked the PSU-connection to the CPU-cooler.


I cant get to the BIOS since the system reboots after like five seconds... :(


So it seems that the only way I can actually check if the pump and cpu-cooler is active, is by the LED-light, which, as I said, is completely dark...

Link to comment
Share on other sites

I got it working now.

I put down a lot of effort for this to happen.


To be sure that the h80i really was the issue, I removed it and installed the stock Intel cooler. The same thing happened then! (Startup, 5 sec, then reboot, over and over again.


What I did then was to deattach every component, except cooler, gfx-card and one memory stick.

After all this the Intel-cooler worked, and the system started up!


I the reinstalled the h80i - and it worked!


Now I am sitting with my new computer and a working h80i :)


Why didnt it work? Dont ask me. Maybe overload from all my hdd:s? (I have a total of 4 installed...)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...