Jump to content
Corsair Community

K90 and M90 Firmware update issue


Recommended Posts

I just recently bought the K90 and M60 mice and keyboard combo to pwn in world of wacraft, plugged it into my computer, and all worked fine. It was until that I installed the firmware update for both my mouse and keyboard is when it all went downhill. Before, everything worked. I used the downloaded drivers to controll my backlight on my mouse and keyboard. Was still trying to figure out how to use the G-keys, but that was when I decided to install the firmware update.


I installed the update, but as soon as it finished installing, my keyboard and mouse stopped responding! So I unplugged it from my USB 3.0 port on my computer and plugged it into another port. My computer recognized it but now it only recognizes it as a standard twenty dollar keyboard! I've tried everything to unstalling and reinstalling, http://forum.corsair.com/forums/showthread.php?t=104856, changing USB ports, nothing worked!


My keyboard and mouse still work (I'm typing on it) but none of the G-keys, backlights, M1, M2, M3, or media keys work! Same with the mouse, it's just a standard mouse now with no DPI controls. Is there anyway that I can restore my mouse and keyboard to factory settings?


Silly me for updating the firmware. I guess the saying goes true, "If it isn't broken, don't fix it!"


I'm very frustrated. Please, help.

Link to comment
Share on other sites

Does device Manager detect the K90 and M90?

K90 - Corsair Gaming Keyboard

M90 - Corsair M90 Gaming Mouse

Uninstall the K90 and M90 software and restart your computer.

Make sure the devices are plugged into a USB 2.0 port.

Open up Task manager and close any related M90/K90 processes if they are still there.

Install the firmware updater and see if it can reflash the device.


If not, post the message it says on the screen.

Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...