Jump to content
Corsair Community

Link kit not detected in 2.X.X?


Recommended Posts

Recently purchased a Corsair Link Cooling/Lightning Kit?

Tried installing LINK 2.X.X dashboard software to find nothing is detected?


There is a chance that your Commander unit is still on the old firmware (1.1.9).


This thread will cover the update process from firmware 1.1.9 to 2.0.6, (Required for LINK 2.X.X)


1. Download the firmware update archive. CorsairLinkUSBFW_2.0.6.zip


2. Un-zip the archive by dragging the file to the Desktop or C:\.


3. If you have installed LINK 2.X.X, Uninstall it. Then install LINK 1.2.7 Beta


4. Launch the dashboard and click Tools > Device Management (Screenshot below)



5. A window should now pop-up, Click Update Firmware. (Screenshot Below)




6. The firmware updater windows should now display.


7. Under Device, click the drop-down arrow and select Corsair Commander, for file. click the ellipsis and browse to the .s19 file.


8. The firmware updater screen should look like this when step 7 is completed.



9. Click "Start" and let the firmware update take place.


The firmware update will complete when you see this message "Status: Bootloader Done". You have successfully updated the Commander unit firmware to 2.0.6


Other Links


Corsair Link: Links to everything!

Updating firmware on LINK 2.X.X




Link to comment
Share on other sites

  • 2 weeks later...

Thanks for your excellent, concise summary of this procedure.


I am grateful to you for taking the time to assemble this information, and for titling it so that it is easy to find. You made it easy for me to get my newly shipped Commander up and running.

Link to comment
Share on other sites

I was so happy to find this thread;

1) It was easy to find. The title matched the problem.

2) Like jt-home, above, I found this concise and accurate.


I have had the H100 for about two weeks now, after all that time, checking my install both physically and software wise, cruising forums (mainly this one), I still had no joy. However, this post set me straight in about five minutes.:laughing:


Thank you, Toasted

Link to comment
Share on other sites

  • 1 month later...

Thank you for that Concise explanation and instruction,, I have been pulling my hair out trying to get the cooling and lighting kit to work with my H80i and link software after receiving it today, had my system to bits about 10 times checking everything!!! why do they send the commander unit out with outdated software, why is there no reference to any of this in instructions which you get none with kit. CORSAIR hang your heads i shame. what a pallarver I have had.

Still sorted now, no thanks to you Corsair :sigh!::sigh!:

Link to comment
Share on other sites

Are you referring to the H80i/H100i coolers?


The plug next to the USB port is for a Corsair LINK compatible device. e.g. AXi Series PSU or to connect it to the Commander unit.


There is a detection issue when the Hydro Series i cooler is plugged into the Commander unit. This should be fixed when a SW/FW update comes out.


What did you try that caused the fans to stop and no L.E.D. to light up?

What did you plug it into?

Link to comment
Share on other sites

I retried this again now firmware has been updated and it seems to be working fine now, when I tried it before it will have been because the Commander module was not recognized in link software and it had lost control of fans. My only other issue with it now is,,, why are my hard drives showing temps of 120 deg C and reading off the temp probe my 990 northbridge chip on my Gigabyte 990FXA-UD3 is showing idle temp in excess of 65 Deg C???? the case has 2-200mm fans running.
Link to comment
Share on other sites

Well I was reading the temp from directly under the NB chip heatsink but now the probe seems to have gone Kaput??? I know the hard drives are reading barmy temps through SMART but still after paying all the money out for this lot you would kind of expect it to work properly!! wouldn't you, very problematic and the email I sent to Corsair support,, well they have not even bothered to answer, and here was me thinking a good reputable company.

I'm not a happy puppy to say the least...............

Link to comment
Share on other sites

  • 9 months later...


This topic is now archived and is closed to further replies.

  • Create New...