Jump to content
Corsair Community

(the) DOMINATOR strikes again


Recommended Posts

So i've been using 2x2gb dominators for the past few months now, with no problem at 800mhz, but recently i've managed to install W7 x64, so i said what the heck, i've gone full 4 gigs why not 1066mhz? problem is i have no idea how to do this. I've read lots of articles i've even tried 5-5-5-15 2T at 2.1(which took a whole day to figure out what this numbers even mean) but no luck, all i get is blank screen with a beeping white line. I reset the computer and the bios goes back to default. So how can I get it to run at 1066mhz? I've also attached a few pics of how my bios looks like and of some of the changes i tried.


Beware , i'm no computer wizz, i'm a bit nubbish when it comes to OC and bios using , so try to dumb things down a bit :D:








Link to comment
Share on other sites

DDR2 1066 MHz. RAM only works for two specific RAM slots on AM2+/AM3 socket mobos so be sure that you are using the correct slots. Your Asus manual should advise which slots must be used. Also make sure that you have the latest BIOS and check with Asus to see if they've had issues with this specific mobo with RAM @ 1066 MHz.



Link to comment
Share on other sites

i've already read the manual, it just says that the mobo is limited to one DIMM 1066mhz per channel , so i've put the first stick in A1 and the second one in A2 with not visible difference. Guess i'll go through it again, maybe there's something i've missed.


If anyone has any idea, feel free to share!

Link to comment
Share on other sites

something odd happened when i did that, my monitor started "blinking" in windows, and the BIOS got a bit solarized. any idea why?


EDIT: Fixed it, took the sticks out, put them back, in reset, unplugged pc, put them back in yellow, works fine. Still only works on 800mhz thou.


EDIT2 : I think i made them work, when i boot it shows me their at 1066mhz, but everest shows me it's still 800mhz, how can i find out which is the real frequency ?


EDIT3: Wasn't stable, crashed after 30 min, blue screen of death and i just couldnt enter windows (froze at loading) or BIOS just kept saying WAIT , had to reset cmos.

Link to comment
Share on other sites

You can see you memory speed and timings with CPU-Z.

Have you tried Memtest? Test one stick at a time in each slot for at least four passes.

It will take a few hours so be patient.


There's a link for both in the box on the left side at the top of this page.

Link to comment
Share on other sites

  • 4 weeks later...

i've managed to set them to 1066mhz at 1.9 v, with 2T and everything else set to auto, it's the only mostly stable way to get them to this frequency, the only problem is now that i get a bluescreen once every few hours, so i was wondering if anyone knows what timmings should i be using at 1.9 , i'm thinking the auto ones might be flawed, maybe it might make the RAM more stable.? Any thoughts?


in case ur wondering what bluescreens i've been getting, there to fast to write down but this is what i've manged to see and remember: 0x00000003b, 0x0000008 and nvlddmkm.sys


Edit: just got 0x0000001a


I'm gonna do a memtest tonight since it takes so long.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...