Jump to content
Corsair Community

SDK - Events Example - CorsairSubscribeForEvents not working on v4.24.193 various hardware


Recommended Posts

I have two very similar machines happily running older K95s and more modern cue v4 compatible hardware, such as Scimitars.

I upgraded v4.23.137 on one of two machines to v4.24.193 and suddenly, my executable which was very similar to the example stopped functioning.  It does register connections and disconnections, but no longer responds when G or M keys are pressed.

To diagnose this, I have tried clean uninstall of icue on subject machine, reboot, update windows and nvidia drivers, reboot, clean (manually remove) all corsair folders everywhere, sfc/etc, reboot, fresh download of 4.24.193, install, reboot, download newest events_example from github, open solution, retarget, remove spectre mitigation, build, run exe, and the exe cannot see g or m key presses but handshake works fine, no errors on registering for events and it is allowed in the settings in icue.  Tried specifically disallowing and then re allowing.  Tried alternate hardware, no difference on subject machine.  Services are running and restarting the services does not help.

Same hardware works on alternative machine (18 key K95 and Scimitar Pro).  Save av / am services on both machines.  If anyone has any ideas of what else I can look for in diagnosing this? 

Working machine is on v4.23.137 on win 10 N Pro 19044.1706 and not working machine is Windows 10 Pro 19044.1741.  Have doubts that version differential is the issue.

Link to comment
Share on other sites

I have even tried a brand new installation of Windows 10 and fresh install of icue with zero other software installed and its just not working.  The remaps work inside of icue, which makes me think something is broken only with the key event registration.

Link to comment
Share on other sites

quick update, not to bump but reinstalled an icue 3 release on new windows machine, and it works fine.  tried in place upgrade to prior version 4.23.137 (which is what I am using on the working machine) and it stopped working.  May try an earlier release of v4 from v3 after clean uninstalls and reboots, then upgrade to 4.23.137 and see what happens...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...