Jump to content
Corsair Community

RGB not working for all fans


Recommended Posts

I recently built a new system and I'm having a demon of a time trying to get all of my fans LED to activate.  I have the following:

5000x case

H100i elite Capellix

I'm using the 3 fans that came with the case, one additional SP120 RGB Elite in the rear, and the two fans that came with the cooler, for a total of 6.  For whatever reason, I cannot get RGB on all 6 fans.  Using the PWM controller and lightning core built into the case I was only able to get 4 fans to light up (the three in the front and one of the cooler fans).  When I use the command core I was able to get all but the two cooler fans to light up.  I tried a commander core XT and all 6 fans lit up at boot but the minute windows loaded I lost one RGB on one cooler fan, which is where I currently stand.

Any advice on what may be going on?  I don't think it's faulty hardware since I've seen all the fans fully functional.

Link to comment
Share on other sites

Make sure you have set the Lighting Setup to “8 LED series x 6” and not SP-RGB or ML-RGB that only have 4 LEDs. 
 

The Commander Core and XT have individual RGB port detection whereas the Lighting Node Core from the case is serial like most other controllers. This means you may get different results when something is wrong depending on the controller in use. You must use the Commander Core to power the pump on the Elite Capellix unit, so it would make sense to use that as your RGB controller as well. There’s no need to use another unless you have more than 6 fans. 
 

RGB and fan motor functionality are completely separate, hence the two different power wires on the fan. If I rip off the PWM wire, it should still light up and vice versa. Can you be specific about which fan(s) do not light up when on the Commander Core or XT?  Fan type and RGB header #?  If it’s really the fan, it should still occur when you swap it. To a different position. 

Link to comment
Share on other sites

The ML 120 fan on the cooler furthest from the pump refuses light to light up.  I did try swapping it with the fan next to it (I have the cooler fans on header #5 and #6) and interestingly BOTH cooler fans stopped lightning up once iCue loaded.

One common thing I've noticed is every time I swap the RGB cables around all the fans have RGB functioning at boot and they remain on when I go into BIOS.  Once Windows boots fully that's when I lose the fan RGB and it remains gone until i swap the cables again.

Link to comment
Share on other sites

Which controller are you using now?  If the Commander Core or XT, try manually setting the configuration to 8LED series x 6 in Lighting Setup. 
 

Start a support ticket with Corsair now. It seems likely one of the MLElite OEM fans has a defect. 

Link to comment
Share on other sites

I put everything back in the commander core and I'm not getting light on either cooler fan.  I tried manually setting and no luck

Link to comment
Share on other sites

Contact Corsair Support.  In the ticket, specifically draw attention to the controller (Commander Core), you've manually set it to 8 LED series x 6, and that when you swap the two ML-Elite OEM fans at 5-6 one can turn off the other.  Those are the clues it is not a configuration issue and something is wrong on one or both of the ML-Elites.  I may be on the return signal from the one fan that knocks out the other, but they may send you 2 new fans regardless to cover other possibilities.  

Link to comment
Share on other sites

14 hours ago, c-attack said:

Contact Corsair Support.  In the ticket, specifically draw attention to the controller (Commander Core), you've manually set it to 8 LED series x 6, and that when you swap the two ML-Elite OEM fans at 5-6 one can turn off the other.  Those are the clues it is not a configuration issue and something is wrong on one or both of the ML-Elites.  I may be on the return signal from the one fan that knocks out the other, but they may send you 2 new fans regardless to cover other possibilities.  

Thanks!  I have a ticket in, let's see what happens

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...