Jump to content
Corsair Community

Corsair H115i missing in settings


k-i-b
 Share

Recommended Posts

i have looked the forum up>down> here and there without finding a single thread.
im trying to force a firmware upgrade on my h115i cooler, but icue will not list the cooler in settings. the cooler is tho both on home page and on dasboard. i have tried to stop icue, stop all services( 3 ) and restert icue. still no way to upgrade my fw. reason i need to do this was because icue "lock up" my cpu fan. i can change fan profile anything i want, but after 5 minutes or so, the fan stay put on 850 rpm. 
any other way to make icue see my h115i on the setting page?

Link to comment
Share on other sites

Which H115i?  There are several versions across multiple generations. 
 

Lock up your cpu fan?  None of the H115i coolers are powered by a motherboard header. All are SATA powered and then there is 1 tachometer to cpu fan to satisfy the MB’s cpu fan safety feature. All this does is report a rpm to the motherboard. Your bios controls have no effect on the cooler. 

Link to comment
Share on other sites

10 hours ago, c-attack said:

Which H115i?  There are several versions across multiple generations. 
 

Lock up your cpu fan?  None of the H115i coolers are powered by a motherboard header. All are SATA powered and then there is 1 tachometer to cpu fan to satisfy the MB’s cpu fan safety feature. All this does is report a rpm to the motherboard. Your bios controls have no effect on the cooler. 

problem solved for now, had to do some updates on asus armoury. my cooler is a H115i hydro . 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...