Jump to content
Corsair Community

iCUE H150i ELITE CAPELLIX Liquid CPU Cooler firmware failed V.2.10.219


Recommended Posts

Currently going through the same issues. I don't think I can override the controls through BIOS. It's a shame they would throw an update and not properly HARD TEST the firmware. I honestly want to switch with another company for components but I actually favor the iCue software....

Link to comment
Share on other sites

Hey,

Updated my H100i Elite Capellix last week. No problems during the update. My pump did start to whine like crazy after this update. 

It's weird because my AIO is just three weeks old.

Just putting it out there for anyone that may run into this issue. Getting in to contact with my local retailer soon for a solution. 

Link to comment
Share on other sites

  • 2 weeks later...

Yup, 2.10.219 failed for me too. Tried twice. I switched the PSU off and back on, thankfully the H150i still worked. I've been waiting for a newer version that hopefully fixes this.

Link to comment
Share on other sites

  • Corsair Employees
On 4/30/2022 at 7:35 PM, ChicagoOutfit said:

Hi has anyone had any issues trying to update the firmware and it fails and pretty much bricks the cooling system? When I try to update the firmware it fails and I have no idea why.

 

On 5/1/2022 at 6:40 PM, DeathReaver said:

Yea, mine did the same. it's bricked AF

 

Sorry to hear you guys had issues with the update.  Please reach out to our support staff by opening a ticket at https://help.corsair.com

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...