Jump to content
Corsair Community

Corsair 220T RGB SP120 Fans Have Not Properly Worked Since I Bought the Case


Recommended Posts

Like the title says, I swear this case has its own personality. Currently the top and bottom fans are both green. What does iCue say they are supposed to be? Red Top Green Bottom. Middle fan doesn't even have a color and it's supposed to be Yellow. If I were to restart the computer, they would likely be either not on at all or maybe one of them would be on and a color of its own choosing. Any ideas where to start for troubleshooting? For reference, I have already traced all of the wiring to make sure each fan is plugged into the right ports. Yes the PWM wires are plugged into the motherboard. Yes the RGB wires are plugged into the built-in iCue controller. Yes iCue is set to SP120 fans. Yes they are selected in the right order for color coding. Software version 0.19.16. I have had the case since December 2021 and have been off and on googling to figure out what to do but now I have created a profile just for this issue. What do?? Thanks.

Link to comment
Share on other sites

the Lighting Node Core software is 0.19.16. iCue is at 4.22.203

Link to comment
Share on other sites

In CUE change the "Lighting Set-up" to "8 LED series fan" x 3.  You don't have "SP-RGB fans".  Those are an older discontinued 4 LED fan that does not work with any of the others.  You have SP-Pro fans that are part of the 8 LED center hub series, along with the SP-Elite and ML-Elite.  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...