Jump to content
Corsair Community

Corsair Dark Core RGB Pro doesn't work after reboot


Recommended Posts

I bough Corsair Dark Core RGB Pro 1 month ago , and was working fine with my old XPS 13 9730 flawlessly , however when i tried using it with my new work laptop Latitude 7420 i faced strange issue.

 

When i connect the mouse reciever after logging to windows it works fine with no issue , however if i connected it before loggin to windows or booting the laptop , the mouse is detected in iCue but doesn't work .

 

I can control the lighting in iCue but mouse cursor and buttons are not working, it only works if i unplug the reciever and plug it again.

 

did anyone faced similiar issue.

 

I tried latest iCue version ,and older version .

 

I don't have same issue with other devices like corsair void pro wireless ,microsoft keyboard , or logitech mouse.

 

also i tried the mouse through usb-c hub and direct with same result

Link to comment
Share on other sites

  • Corsair Employees

Hi ahmedsamih,

 

Please review the below helpdesk article and see if it resolves things for you:

 

https://help.corsair.com/hc/en-us/articles/360058128911-How-to-Fix-issue-where-keyboard-temporarily-does-not-work-after-Windows-boot

 

If it doesn't, please open a ticket with support using the Support Ticket system link at the top of this page.

 

Thank you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...