Jump to content
Corsair Community

K100 RGB keyboard defaulting to red lights


miles326
 Share

Recommended Posts

While I absolutely love the K100 keyboard, I encountered a problem with it a few days ago. Instead of sticking to the rainbow spiral, or anything else I change it to, all the lights are stuck on red. This also affected my Dark Core Pro mouse whose lights are also stuck on being red. The problem fixes itself if I close the ICUE software and restart it, but the problem returns next time I turn the PC on. Any ideas?
Link to comment
Share on other sites

  • Corsair Employees
Can you confirm which version of iCUE you have installed? You can check under the settings tab of iCUE. Also, double check that you don't have any settings applied via Instant Lighting at the top. This will overwrite lighting for all your iCUE compatible devices. If you have any other profiles that you created with a red lighting effect, you might be selecting a button to change profiles, and it is changing to that one.
Link to comment
Share on other sites

The software is version 3.34.170.

 

I have only one profile active and I made sure that instant lighting was disabled.

 

EDIT: I figured it out! Turns out the MSI Dragon Center software somehow changed the RGB settings. I changed it and it's all working now.

Edited by miles326
Link to comment
Share on other sites

  • 2 weeks later...
What did you change in Dragon Center? I also have an MSI motherboard and ran into this issue today. I tried unlinking the device but that did not work.

 

Go to the Mystic Light menu, then click the cogwheel setting next to Mystic Light. There should be an option for allowing Dragon Center to override third party RGB settings. Simply turn it off. Dragon Center also does have RGB settings similar to Corsair's if you don't want to turn it off.

  • Like 1
  • Confused 1
Link to comment
Share on other sites

  • 4 months later...
 Share

×
×
  • Create New...