Jump to content
Corsair Community

Escape Key Triggering Middle Mouse


Starworshipper
 Share

Recommended Posts

I've never had this issue until recently, but whenever I have more than one profile added to iCue, my escape key suddenly rebinds to 'Mouse 3.'

 

I don't have any rebinds put in place, just color settings, but whenever I press 'Escape' it triggers 'Mouse 3'

 

  • If I close iCue, the issues goes away.
  • If I reinstall iCue, the issue goes away until I add a second profile, at which point the issue comes back.

 

Any ideas?

 

 

Edit: In an attempt to narrow things do, it looks like it happens whenever I save an action to my action library, but it doesn't matter what kind of action it is. I remapped my 'Sniper' key to be 'Mouse3,' saved that action to my library, and as soon as that action is in my library the issue occurs.

Edited by Starworshipper
More details
Link to comment
Share on other sites

There's a known problem with the latest release of ICUE (v3.22.74) which seems to cause a range of issues with actions. Indeed, you found the temporary "fix" by deleting all the actions from the library. The other way at this time is to downgrade to the previous version of ICUE but that will disable all of your profiles as they have been upgraded when you updated to the latest ICUE.
Link to comment
Share on other sites

  • 1 month later...
There's a known problem with the latest release of ICUE (v3.22.74) which seems to cause a range of issues with actions. Indeed, you found the temporary "fix" by deleting all the actions from the library. The other way at this time is to downgrade to the previous version of ICUE but that will disable all of your profiles as they have been upgraded when you updated to the latest ICUE.

 

I have a similar issue on my k95; when I press escape in my default profile it runs a macro from my Overwatch profile.

 

I am running 3.23.66, is this still going on for you guys or was it fixed and I am the only one?

Link to comment
Share on other sites

I have a similar issue on my k95; when I press escape in my default profile it runs a macro from my Overwatch profile.

 

I am running 3.23.66, is this still going on for you guys or was it fixed and I am the only one?

 

Nope, same here.

I once created a macro that presses sa2 when I press space, but that was months ago. It's gone. Now Escape types sa2 for me everytime I use it, which is quite annoying and often leads to items I didn't intend to use in a game and so on.

 

iCUE 3.23.66 with a K70 RGB

 

EDIT: Apparently I fixed it! It doesn't occur anymore, even after restarting.

I soft-resetted my keyboard and uninstalled and reinstalled iCUE after a restart. Escape doesn't trigger anything anymore now, even after recreating my different profiles with macros.

Maybe another key now triggers something, but I haven't found any issues yet. Works fine!

Edited by Cipheria
Link to comment
Share on other sites

My escape key was triggering the G1 macro, F1 was triggering G2 macro, and F2 was triggering G3 macro. It was super annoying. I am working with support to figure it out but constant reboots, uninstalling, and soft resetting the keyboard didn't work. If i save the macro to the library it comes back. If i don't have the Macros to the library everything seems to work fine.
Link to comment
Share on other sites

 Share

×
×
  • Create New...