Jump to content
Corsair Community

Why is iCUE causing random desktop lag?


BuldozerX
 Share

Recommended Posts

Ever since I`ve installed this app my PC has suffered from random desktop lag. It also happens in some games. I Googled it, and I found simular threads from last year made by people with the same issue.

 

Why havent this been solved, and is there any solution to this?

Link to comment
Share on other sites

I have the exact same problem. I can't use windows file explorer while having ICUE in the background. It lags like hell and makes the windows experience soo much worse. In games like minecraft I cant even look around without lagging like crazy. When I close the program I have no problems at all.

 

And the same like you, found a lot of posts on the forum about the same issue and they suggested renaming some DLL's. But this dit nothing at all. Just updated to the latest version and problem still persists.

 

I wish that I didn't buy corsair watercooling and K70RGB Lux... Now im stuck to forcefully use the software with a crappy windows experience.

 

Corsair, it has been over a year. Why is this still an issue???

Link to comment
Share on other sites

I have the exact same problem. I can't use windows file explorer while having ICUE in the background. It lags like hell and makes the windows experience soo much worse. In games like minecraft I cant even look around without lagging like crazy. When I close the program I have no problems at all.

 

And the same like you, found a lot of posts on the forum about the same issue and they suggested renaming some DLL's. But this dit nothing at all. Just updated to the latest version and problem still persists.

 

I wish that I didn't buy corsair watercooling and K70RGB Lux... Now im stuck to forcefully use the software with a crappy windows experience.

 

Corsair, it has been over a year. Why is this still an issue???

 

I have the EXACT same problem. It totally obliterates windows explorer. I also use Autodesk Inventor for CAD work and it completely ****s on the 3d viewport and makes it stutter and freeze so bad it's unusable. I have to kill iCue to have a PC that doesn't feel like it's 10 years old. I wonder how many people have these kinds of issues and don't realize it's caused by iCue. I've done the DLL rename from one of the other threads and that doesn't help at all either. I submitted a ticket to support for it (#2000794485)

Edited by jwalker55
Link to comment
Share on other sites

I have to say, I have today done a completely fresh install as part of a new Ryzen build.

 

iCue definitely has been the one software giving me a laggy desktop experience when I open/interact with it.

 

I made sure to turn off g-sync windowed mode in case that was having any efect but same problem.

 

Is iCue going to be updated to talk more nicely to the Ryzen CPUs or to just be a bit more light weight, it feels "heavy" if that makes sense

Link to comment
Share on other sites

This is not a commonly reported problem unless you are trying to use Gsync window mode on iCUE. It is an application with graphs and other rendered components.

 

Been having this problem for quite a long time now, but I learned to deal with it since it only happens when I bring iCUE to the foreground. Doesn't matter if I enable G-sync for full screen or windowed. It might be something else.

Link to comment
Share on other sites

 Share

×
×
  • Create New...