Jump to content
Corsair Community

K70 RGB LED glitch


Recommended Posts

I posted this on CUE forum before. Gonna post it here again since I really want to fix it. Still don't want to get an new one just because some LED problem.


My K70 RGB indicator light display wrong color after running iCUE


My current system did not have any CUE or iCUE install and the kb runs on on-board profile.

After install iCUE, it cause the Brightness indicator and Win lock indicator to display wrong color.

- Brightness led can not emit green (turns white to magenta)

- Win lock can not emit red (turns white to cyan)


The cause from wear or damage is unlikely since they are both malfunction at the same time.

When clear all lighting (but on full brighness), some key on bottom-most row emit faint green and media key have faint red.


Tried the following


- Unplug / Restart

- Downgrade to CUE

- Downgrade CUE even more

- Downgrade firmware to 1.3

- Reset by ESC and plug


Trying next


- Run on different OS


Currently I have tried install iCUE on different Windows image (still 7x64)

The problem is still there.


I can list a few things that could cause the problem all of which are unlikely


- Full bath cleaning : once a year, dried properly. Never have any trouble

- Running CEE without CUE (I'm quite sure I did this many times without problem)

- Running CEE with iCUE (This sure is something I never did and the problem start right afterward)


Will try to open it up one last time to check the board and wires.


Is there any paid repair service or other solution in the case that it can't be fixed with software or firmware? Bought this back in 2015 it's the model with smaller key label and ugly gaming logo (not the sails). Open it up and clean every year or half so the warranty is long gone.

Link to comment
Share on other sites

The red green and blue work fine for the whole board except two buttons in 'performance' category... Brightness and WinLock


If I set Brightness to full green 255 or green at any level, it just go black.

And same on WinLock but red is not working in this case.


Some other standard keys on bottom row or next to bottom row are green (very faintly) when set to max brightness but on black (0,0,0) or no light (blank).


edit: I did a full bath just a week or so before the problem shows up. Even then, it still work fine until I mixed CEE with iCUE.


I plug it on 2 USB2 ports if that help somehow. Never tried USB3 port.

Didn't expect such a quick response. Appreciate it.


Also iCUE not saving profile to memory and have no feedback on click (no big deal, I can still use old CUE) So the lighting revert to whatever it is when quit.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...